No Crashdump and Compaq Systems with Smart-2/P (PCI) Controller

This article was previously published under Q166874
This article has been archived. It is offered "as is" and will no longer be updated.
Symptoms
On Compaq systems running a Smart-2/P (PCI) controller as the boot device,a blue screen error may not generate a crashdump file. This occurs eventhough the crashdump requirements are met.
Cause
Compaq 1500 and 5000 systems frequently run a Smart-2/P (PCI) controller tocontrol the disk drive containing the Windows NT boot partition. A specialWindows NT function call contained in the PCI Find Adapter routine returnsan error condition when called at crashtime. As a result of this, the PCISmart-2/P adapter is not found to be present at crashtime and no crashdumpfile is generated.
Resolution
A new version of Cpqarray.sys is available to correct this problem. Compaqhas included this hotfix in their Softpaq - SP2746.exe. They have alsoindicated that it will be incorporated in the upcoming SSD 1.21 release.
Status
Microsoft has confirmed this to be a problem in Windows NT version 4.0.This problem was corrected in the latest Microsoft Windows NT 4.0 U.S. ServicePack. For information on obtaining the service pack, query on the following wordin the Microsoft Knowledge Base (without the spaces):
S E R V P A C K
prodnt 4.0
Properties

Article ID: 166874 - Last Review: 11/02/2013 17:59:00 - Revision: 2.0

  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Server 4.0 Standard Edition
  • kbnosurvey kbarchive kb3rdparty kbbug KB166874
Feedback