Client Cannot Resolve MX Record via Microsoft DNS Server

This article was previously published under Q173676
This article has been archived. It is offered "as is" and will no longer be updated.
Symptoms
When you use a Microsoft Windows NT version 4.0 Domain Name Service (DNS)server, your clients may not be able to successfully resolve mail servernames to IP addresses.
Cause
The DNS client is sending a recursive query to the Microsoft DNS server,which is forwarding that query to a BIND-based DNS server. Some BIND-basedDNS servers return a Start of Authority (SOA) record with a ResponsibleAuthoritative Mailbox field instead of a Mail eXchange (MX) record. If theauthoritative DNS server for the domain in which the mail server resides isone of these BIND-based DNS servers, the Microsoft DNS server will notreturn that record to the client.
Resolution
To resolve this problem, obtain the latest service pack for Windows NT 4.0 or Windows NT Server 4.0, Terminal Server Edition. For additional information, click the following article number to view the article in theMicrosoft Knowledge Base:
152734 How to Obtain the Latest Windows NT 4.0 Service Pack

Status
Microsoft has confirmed that this is a problem in Windows NT 4.0 and Windows NT Server 4.0, Terminal Server Edition. This problem was first corrected in Windows NT 4.0 Service Pack 4.0 and Windows NT Server 4.0, Terminal Server Edition Service Pack 4.
Properties

Article ID: 173676 - Last Review: 10/26/2013 04:23:00 - Revision: 2.0

  • Microsoft Windows NT Server 4.0 Standard Edition
  • kbnosurvey kbarchive kb3rdparty kbbug kbfix kbnetwork KB173676
Feedback