XADM: Upgrade to Exchange 5.5 Fails If Virus Software Is Enabled

This article was previously published under Q178302
This article has been archived. It is offered "as is" and will no longer be updated.
Important This article contains information that shows you how to help lower security settings or how to turn off security features on a computer. You can make these changes to work around a specific problem. Before you make these changes, we recommend that you evaluate the risks that are associated with implementing this workaround in your particular environment. If you implement this workaround, take any appropriate additional steps to help protect your system.
Warning This workaround may make your computer or your network more vulnerable to attack by malicious users or by malicious software such as viruses. We do not recommend this workaround but are providing this information so that you can implement this workaround at your own discretion. Use this workaround at your own risk.
Note An antivirus program is designed to help protect your computer from viruses. You must not download or open files from sources that you do not trust, visit Web sites that you do not trust, or open e-mail attachments when your antivirus program is disabled.

For additional information about computer viruses, click the following article number to view the article in the Microsoft Knowledge Base:
129972Computer viruses: description, prevention, and recovery
SYMPTOMS
When you attempt to upgrade Microsoft Exchange Server versions 4.0 or 5.0to Microsoft Exchange Server version 5.5, errors may occur and you receiveone of the following error messages:
Microsoft Exchange Server Setup
An internal initialization error occurred in the database
upgrade process.
Microsoft Exchange Server Setup
ID: no. c1032bfc
<OK>
Microsoft Exchange Server Setup
ERROR: Your upgrade did not complete successfully. Please restart your
Microsoft Exchange Services and your system will behave as it did before
the upgrade was attempted.
Please contact Microsoft Product Support Services for more information.
Microsoft Exchange Server Setup
ID: no. c1032c07
<OK>
Microsoft Exchange Server Setup
ERROR: Your upgrade did not complete successfully. Please restart your
Microsoft Exchange Services and your system will behave as it did before
the upgrade was attempted.
Please contact Microsoft Product Support Services for more information.
Microsoft Exchange Server Setup
ID: no. c1032c08
<OK>
CAUSE
When certain virus checking programs are installed, they add various FileSystem Filters as devices. These devices are enabled automatically (or whenthe server is started) and prevent JET 97 (ESE), the Microsoft ExchangeServer 5.5 database, from installing and functioning correctly.
WORKAROUND
The workaround that is presented below will allow the setup programcomplete the upgrade to Microsoft Exchange Server version 5.5. However, toensure that Microsoft Exchange Server database utilities will functionproperly, you should obtain and install a post-Service Pack 3 hotfix forWindows NT 4.0 before you restart any virus software programs on aMicrosoft Exchange 5.5 Server computer.

  1. Disable the anti-virus software. Double-click the Services icon in Control Panel to set the appropriate services to Disabled.
  2. Disable the system devices. Double-click the Devices icon in Control Panel. Set the appropriate system devices to Disabled.
  3. Stop all Microsoft Exchange Server Services and set them to Manual startup.
  4. Restart the server and then proceed with the upgrade.
RESOLUTION
To resolve this problem, obtain the latest service pack for Windows NT 4.0 or Windows NT Server 4.0, Terminal Server Edition. For additional information, click the following article number to view the article in theMicrosoft Knowledge Base:
152734 How to Obtain the Latest Windows NT 4.0 Service Pack

STATUS
Microsoft has confirmed this to be a problem in Microsoft Windows NT Serverversion 4.0 Service Pack 3. This problem was first corrected in Windows NT 4.0 Service Pack 4.0 and Windows NT Server 4.0, Terminal Server Edition Service Pack 4.

For your convenience, the English version of this post-SP3 hotfix has beenposted to the following Internet location. However, Microsoft recommendsthat you install Windows NT 4.0 Service Pack 4 to correct this problem.NOTE: Review the Readme.txt file in that directory before you attempt toinstall the hotfixes.


For additional information, please see the following article in theMicrosoft Knowledge Base:
174748XADM: ESEUTIL /g Returns Error -1022
c1032bfc upgrade 5.5 innoculan exfaqoldad exfaqold
Properties

Article ID: 178302 - Last Review: 02/24/2014 08:31:30 - Revision: 5.1

  • Microsoft Exchange Server 4.0 Standard Edition
  • Microsoft Exchange Server 5.0 Standard Edition
  • Microsoft Windows NT 4.0
  • kbnosurvey kbarchive kbbug kbfaq kbfix KB178302
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