WD98: How to Create a Mail Merge Using Data from WordPerfect

This article was previously published under Q178913
This article has been archived. It is offered "as is" and will no longer be updated.
This article provides detailed instruction on creating a simple mail mergeusing data stored in a WordPerfect Secondary file. By following theseinstructions, you will convert the WordPerfect Secondary file to a Worddata document, create a form letter (main document), select the Word datadocument, and merge the information from the two documents into a thirddocument.

NOTE: Microsoft Word 98 Macintosh Edition is shipped with only oneconverter for WordPefect documents. The converter shipped is for WordPefect5.x for MS-DOS and Windows. If the data was stored using another version ofWordPefect, it will be necessary to convert this data to a format thatMicrosoft Word 98 Macintosh Edition can access.

The easiest method is to create a new WordPerfect 5.1 Secondary document ina data document format that Word can use directly in a mail merge.


To convert the WordPerfect 6.x data file to a Word Perfect 5.1 Secondaryfile, follow these steps:
  1. Open the secondary file in WordPerfect.
  2. On the File menu, click Save.
  3. In the Format list, click WordPerfect 5.1/5.2.
  4. Type in a new file name.
  5. Locate the folder where the file is to be stored.
  6. Click OK.
NOTE: In the new file, each record should appear on a separate page andshould have the same number of {END FIELD} codes. If any record containsfewer {END FIELD} codes than any other record, that record will cause anerror when used in a Word mail merge. To prevent this error, insert an {ENDFIELD} code as a placeholder for each missing data category in eachrecord.


Open the WordPerfect 5.1 Secondary document in Word and save the file as aWord document. To do this, follow these steps:
  1. Start Microsoft Word 98 Macintosh Edition by double-clicking the Microsoft Word icon in the Microsoft Office 98 folder.
  2. On the File menu, click Open.
  3. Navigate to the folder where the WordPerfect secondary file is stored.
  4. Change the List Files Of Type selection to "All Files," and then select the WordPerfect secondary file, and click Open.

    NOTE: The data in the WordPerfect secondary file should appear in a table format in the Word document. If it is not in this format, either the format of the WordPerfect secondary file is incorrect, or the converter for WordPerfect 5.1 files has not been installed. To install the converter, follow the instructions later in this document.
  5. On the File menu, click Save As.
  6. Under, "Save file as type," select Word Document.
  7. Locate the folder where this document is to be stored.
  8. Enter a name for the document in "Save Current Document As."

    TIP: The name should indicate that this is a data document (for example, call the file "My Merge Data") and the folder selected should be the same folder where the main document will be stored.
  9. Click Save.
This document can now be used by Word as a data document in a mail merge.


To create the main document, follow these steps:
  1. Start Microsoft Word 98 Macintosh Edition by double-clicking the Microsoft Word icon in the Microsoft Office 98 folder.

    The insertion point should be blinking in Document1. This indicates that Document1 is the active document.
  2. On the Tools menu, click Mail Merge.
  3. Under Main Document, click Create, and select Form Letters.
  4. Click Active Window.
  5. Under Data source, click Get Data.

Selecting the Data Source

To select the data source, follow these steps:
  1. From the list of commands under Get Data, click Open Data Source.
  2. Locate the folder that contains the text data document.
  3. Change the List Files Of Type selection to Word Document, select the file containing the data, and then click Open.
  4. Click Edit Main Document.


The insertion point should be back in Document1 (that is, Document1 shouldbe the active document) and the Mail Merge toolbar should be visible.

To edit the main document (Document1 in this case), follow these steps:
  1. Type some text in the document.
  2. On the Mail Merge toolbar, click Insert Merge Field, and select a field name from the list.

    Repeat steps 1 and 2 as many times as necessary to create the appropriate text and desired number of merge fields in the main document.

    NOTE: When you merge data, you can use as few or as many of the data fields as you need to and you can use them in any order. Also, each field can be used more than one time.
  3. To save the main document, click Save As on the File menu.

    TIP: The name should indicate that this is a Main document (for example, name the file "My Main Document"). The document should be stored in the same location (folder) as the data document.


While in the main document, click the Merge To New Document button on theMail Merge toolbar. This creates a new document containing the results ofthe merge. This new document can be printed, saved, or deleted withoutaffecting either the main document or the data document.

Installing the WordPerfect Converter

To install the WordPerfect converter, follow these steps:
  1. Insert the Microsoft Office or Microsoft Word CD.
  2. Using the Finder, double-click the Microsoft Office CD.
  3. Double-click the Value Pack folder.
  4. Double-click the Value Pack Installer.
  5. Click to select the WordPefect 5.x Text Converter.
  6. Click Install.
  7. Quit the installer
For information about how to do this in other versions of Word, please seethe following articles in the Microsoft Knowledge Base:
141922 WD: How to Start a Mail Merge

140344 WD: How to Convert Data in One Column to a Table for Merging
For more information about mail merge and data document types, click theOffice Assistant, type mail merge data in the query area of the OfficeAssistant and click Search.

NOTE: If the Assistant is hidden, click the Office Assistant button on theStandard toolbar. If Word Help is not installed on your computer,please see the following article in the Microsoft Knowledge Base:
179216 OFF98: How to Use the Microsoft Office Installer Program
form letter mailmerge standard bulk mailing multiple

Article ID: 178913 - Last Review: 10/07/2013 16:27:31 - Revision: 1.2

  • Microsoft Word 98 for Macintosh
  • kbnosurvey kbarchive kbfaq kbhowto kbinfo kbmerge KB178913