XL98: Objects May Not Appear After Copying Worksheet

This article was previously published under Q178985
This article has been archived. It is offered "as is" and will no longer be updated.
SYMPTOMS
When you copy a worksheet in Microsoft Excel 98 Macintosh Edition, thefollowing problems may occur:
  • AutoShapes, drawing objects, charts, and other objects in the worksheet that do not appear or that are represented by placeholders in the original worksheet are displayed. -or-

  • AutoShapes, drawing objects, charts, and other objects appear in one worksheet but not in another worksheet even though they are present in the worksheet.
CAUSE
These problems occur if the following conditions are true:

  • The worksheet you are copying contains one or more embedded charts. -and-

  • Show Placeholders or Hide All is selected in the View tab of the Preferences dialog box (Click Preferences on the Tools menu).
WORKAROUND
To work around this problem, use the following appropriate method to resetthe Objects setting.

Method 1: Objects Are Displayed

If objects appear in the worksheet, use the following steps:
  1. On the Tools menu, click Preferences. Click the View tab.
  2. Under Objects, click the option you want to use. For example, click Show All, Show Placeholders, or Hide All.
  3. Click OK.
The change is applied to all of the worksheets in the workbook.

Method 2: Some Objects Are Not Displayed

If some objects do not appear, use the following steps:
  1. On the Tools menu, click Preferences. Click the View tab.
  2. Under Objects, click Hide All.
  3. Click OK.
  4. On the Tools menu, click Preferences. Click the View tab.
  5. Under Objects, click the setting you want to use. For example, click Show All, Show Placeholders, or Hide All.
  6. Click OK.
The change is applied to all of the worksheets in the workbook.

NOTE: If the Objects setting for the copied worksheet is Hide All, and youcopy the worksheet in a single workbook, objects in the original worksheetmay not be visible even though the Objects setting for the workbook is ShowAll. If this behavior occurs, use the second method in this article torestore the objects on the worksheet to the normal behavior.
STATUS
Microsoft has confirmed this to be a problem in the Microsoft productslisted at the beginning of this article. We are researching this problemand will post new information here in the Microsoft Knowledge Base as itbecomes available.
MORE INFORMATION
In Microsoft Excel 98 Macintosh Edition, you can copy a worksheet by usingthe following steps:
  1. Click the worksheet you want to copy. Then, click Move Or Copy Sheet on the Edit menu. Or, press CONTROL and click the sheet tab of the worksheet you want to copy, and then click Move Or Copy on the shortcut menu.
  2. In the Move Or Copy dialog box, click to select the Create A Copy check box. In the To Book list, click a destination workbook for the copied worksheet. Specify the destination location for the copied worksheet in the Before Sheet list.
  3. Click OK.
The three possible settings for objects in worksheets in Microsoft Excelare listed in the following table.
   Setting             Definition   ------------------------------------------------------------------   Show All            All objects are displayed normally.   Show Placeholders   Objects are displayed in gray; you can see the                       shape of the object but not its contents.   Hide All            Objects are not displayed.				
All worksheets in a workbook use the same settings. You can change thesesettings for the active workbook by clicking Preferences on the Tools menu,clicking the View tab, and selecting different settings.

If you copy a worksheet in Microsoft Excel 98 Macintosh Edition, MicrosoftExcel automatically selects Show All under Objects in the View tab of thePreferences dialog box for the destination workbook. This is trueregardless of the previous setting for the destination workbook.
XL98 kick gray
Properties

Article ID: 178985 - Last Review: 10/07/2013 17:33:15 - Revision: 1.0

  • Microsoft Excel 98 for Macintosh
  • kbnosurvey kbarchive kbbug kbchart kbui KB178985
Feedback