XADM: Cannot Run ISINTEG -PATCH on Cluster Server Computer

This article was previously published under Q185942
This article has been archived. It is offered "as is" and will no longer be updated.
SYMPTOMS
After you run the Microsoft Exchange Information Store Integrity Checker(Isinteg.exe) with the -PATCH option on an Exchange Server computer onwhich Microsoft Cluster Server is installed, you may be unable to start theinformation store. When you attempt to do so, you may receive an errormessage indicating that the information store and directory databases areinconsistent and that you need to run the ISINTEG -PATCH command again.

Note that this problem occurs even when you properly set the_CLUSTER_NETWORK_NAME_ environment variable before you run Isinteg.exe withthe -PATCH option.
CAUSE
When you run Isinteg.exe with the -PATCH option, it modifies the base GUID(generated unique ID or globally unique identifier) used by the informationstore, but it does not notify Microsoft Cluster Server that the change hastaken place. This causes Microsoft Cluster Server to overwrite the new baseGUID, because it thinks the GUID is invalid.
STATUS
Microsoft has confirmed this to be a problem in Microsoft Exchange Serverversion 5.5. This problem has been corrected in the latest U.S. servicepack for Microsoft Exchange Server version 5.5. For information onobtaining the service pack, query on the following word in the MicrosoftKnowledge Base (without the spaces):
S E R V P A C K
MORE INFORMATION
For additional information about setting the _CLUSTER_NETWORK_NAME_environment variable before you run Isinteg.exe with the -PATCH option,please see the following article in the Microsoft Knowledge Base:
178311XADM: Error Running ISINTEG on a Cluster Server
clustering clustered
Properties

Article ID: 185942 - Last Review: 10/08/2013 02:48:14 - Revision: 3.4

  • Microsoft Exchange Server 5.5 Standard Edition
  • kbnosurvey kbarchive kbhotfixserver kbqfe kbbug kbfix KB185942
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