System Hang Results from Large Number of Notify Syncs

This article was previously published under Q186416
This article has been archived. It is offered "as is" and will no longer be updated.
SYMPTOMS
Your computer running Windows NT 4.0 Service Pack 3 (SP3) that isconfigured as a domain controller may stop responding (hang) whenapproximately 400 users with a centralized desktop scheme are connected tothe domain controller.
CAUSE
With this centralized desktop scheme, the most significant network loadcame about when the Start Menu and Desktop were refreshed. The Explorershell from the client causes a series of NotifyChangeDirectoryFile calls tobe made to the file system of the server during these refresh cycles. Eachcall causes a notify sync object to be allocated and places an IRP in thenotify queue.

In this configuration, the 400 users generated a significant number ofnotify syncs, which eventually would create a mismatch between anassociated IRP and its notify synch object because of a timing issue.
RESOLUTION
To resolve this problem, obtain the latest service pack for Windows NT 4.0 or Windows NT Server 4.0, Terminal Server Edition. For additional information, click the following article number to view the article in theMicrosoft Knowledge Base:
152734 How to Obtain the Latest Windows NT 4.0 Service Pack

STATUS
Microsoft has confirmed that this is a problem in Windows NT 4.0 and Windows NT Server 4.0, Terminal Server Edition. This problem was first corrected in Windows NT 4.0 Service Pack 4.0 and Windows NT Server 4.0, Terminal Server Edition Service Pack 4.
Properties

Article ID: 186416 - Last Review: 10/08/2013 02:53:44 - Revision: 1.3

  • Microsoft Windows NT Server 4.0, Terminal Server Edition
  • Microsoft Windows NT 4.0 Service Pack 3
  • kbnosurvey kbarchive kbhotfixserver kbqfe kbbug kbfix KB186416
Feedback