Random Stop 0x50 Errors on Cirrus Video Adapters

This article was previously published under Q188303
This article has been archived. It is offered "as is" and will no longer be updated.
SYMPTOMS
On systems with some Cirrus-compatible video adapters, Windows NT mayrandomly and infrequently stop responding (hang) and report the followingblue screen error message:

STOP 0x00000050 error
PAGE_FAULT_IN_NONPAGED_AREA.
CAUSE
The GDI in Windows NT requires 8-byte alignment on the bitmaps it isexpected to draw on. Cirrus's driver provides 4-byte alignment instead of8. This may cause problems on some video adapters where output requests aredelivered to GDI.
RESOLUTION
To resolve this problem, obtain the latest service pack for Windows NT 4.0 or Windows NT Server 4.0, Terminal Server Edition. For additional information, click the following article number to view the article in theMicrosoft Knowledge Base:
152734 How to Obtain the Latest Windows NT 4.0 Service Pack

STATUS
Microsoft has confirmed that this is a problem in Windows NT 4.0 and Windows NT Server 4.0, Terminal Server Edition. This problem was first corrected in Windows NT 4.0 Service Pack 4.0 and Windows NT Server 4.0, Terminal Server Edition Service Pack 4.
cirus display driver Video capture
Properties

Article ID: 188303 - Last Review: 10/09/2013 17:39:23 - Revision: 2.2

  • Microsoft Windows NT Server 4.0, Terminal Server Edition
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows NT Server 4.0 Enterprise Edition
  • kbnosurvey kbarchive kbhotfixserver kbqfe kbbug kbfix kbqfe KB188303
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