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Printing to Local Port May Fail with Access Denied Error

This article was previously published under Q188878
SYMPTOMS
When sharing a printer that is redirected using a local port to anotherWindows NT computer that is sharing a local printer (LPTx), the followingmessage may appear on the Windows NT computer with the reshared local port.

There was an error writing to \\Computer1\share. Access is Denied.

This message only occurs when other remote clients print to this resharedprinter after the computer with the shared LPT printer is restarted. Theerror occurs regardless of the source of the print job (LPR, SMB,Macintosh, and so on).

The problem does not exist when the target computer is a Windows 95 orWindows 98 computer.
CAUSE
User credentials can only cross one computer boundary, not cross twocomputers. The second session will be opened with "NULL" user credentials.
RESOLUTION
If printing to another Windows NT print server is required, you cansubstitute the reshared local port with an LPR/LPD printer port.
WORKAROUND
As a workaround, set up a null session share on the target NT computer. For additional information, please see the following article in the Microsoft Knowledge Base:
121853 Downlevel Print Jobs Not Redirected Correctly
STATUS
Microsoft has confirmed this to be a problem in Windows NT 4.0. We areresearching this problem and will post additional information here in theMicrosoft Knowledge Base as it becomes available.
null session pipes
Properties

Article ID: 188878 - Last Review: 02/22/2007 20:59:47 - Revision: 2.1

Microsoft Windows 2000 Server, Microsoft Windows 2000 Advanced Server, Microsoft Windows 2000 Professional Edition, Microsoft Windows NT Server 4.0 Standard Edition, Microsoft Windows NT Workstation 4.0 Developer Edition

  • kbnofix kbprb KB188878
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