XFOR: POP or IMAP Errors Accessing Mail Store When Disk Is Full

This article was previously published under Q193932
This article has been archived. It is offered "as is" and will no longer be updated.
SYMPTOMS
When a Microsoft Commercial Internet System (MCIS) 2.0 POP3 or IMAP4service accesses a remote mail store that runs out of disk space, thefollowing error may occur when the POP3 or IMAP4 client tries to open themailbox:
ERR Could not open Inbox for '<user name>'.
You may also see the following errors in the Windows NT event log:
Event ID: 40
Type: Error
Source: POP3SVC
Description:
Virtual Server 1: The inbox <path to user's inbox.idx> is corrupt and should be repaired.
Event ID: 3025
Type: Error
Source: RDR
Description:
A write-behind operation has failed to the remote server <server name>.
The data contains the amount requested to write and the amount actually written.
NOTE: This will only occur in heavy stress situations when the SMTPservice is still trying to deliver messages to the full mail store.
CAUSE
The POP3 or IMAP4 service attempts to log on a user to a mail store duringa disk full scenario while the SMTP service is delivering mail to the samefull disk.
WORKAROUND
To work around this problem, stop the SMTP service to reduce the load onthe server hosting the remote mail store. Subsequent POP3 and IMAP logonsshould be processed successfully.
STATUS
Microsoft has confirmed this to be a problem in Microsoft Internet Systemversion 2.0 Mail.
Properties

Article ID: 193932 - Last Review: 10/10/2013 22:27:08 - Revision: 1.1

Microsoft Commercial Internet System 2.0

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