Computer Stops Responding When Creating a Remote Access Session

This article was previously published under Q194178
This article has been archived. It is offered "as is" and will no longer be updated.
SYMPTOMS
When you try to create a remote access connection that uses scripting(such as the Compuserves PAL95 program), your Windows 95 or Windows98-based computer may stop responding (hang). Note that this behaviorhas been reported to occur if your computer uses a NeoMagic videoadapter. These adapters do not allow their memory to be probed.
CAUSE
This problem can occur if a remote access component was not properlyinitializing a local variable. This may cause your computer to read largeportions of memory, including the display memory area, and this may causeyour computer to hang.

RESOLUTION
A supported fix that corrects this problem is now available fromMicrosoft, but has not been fully regression tested and should be appliedonly to computers experiencing this specific problem. If you are notseverely affected by this specific problem, Microsoft recommends that youwait for the next service pack that contains this fix.

To resolve this problem immediately, contact Microsoft Product SupportServices to obtain the fix. For a complete list of Microsoft ProductSupport Services phone numbers and information on support costs, pleasego to the following address on the World Wide Web:


The English version of this fix should have the following file attributesor later:

   File name     Version    Date      Time    Size     Platform   ----------------------------------------------------------------------   Rasapi32.dll  4.10.2000  09/25/98  07:45p  198,656  Windows 98, Windows                                                        95, Windows 95                                                             DUN 1.3				


NOTE: If you plan to use the 128-bit version of DUN, it must be installed before this hotfix. The 128-bit version of DUN preceded the hotfix, and checks the version of the Rasapi32.dll file.
STATUS
Microsoft has confirmed this to be a problem in the products listed atthe beginning of this article.

This problem has been resolved in Microsoft Windows 98 Second Edition.
MORE INFORMATION
This problem has been known to occur with computers that use NeoMagicvideo adapters which do not allow their memory to be probed.

This failure occurs when an application populates the RASENTRY structurewith an szScript and calls RasSetEntryProperties.

For additional information about Windows 98 and Windows 98 Second Edition hotfixes, click the article number below to view the article in the Microsoft Knowledge Base:
206071 General Information About Windows 98 and Windows 98 Second Edition Hotfixes


For additional information about Windows 95 hotfixes, click the article number below to view the article in the Microsoft Knowledge Base:
161020 Implementing Windows 95 Updates
REFERENCES
The third-party products discussed in this article are manufactured byvendors independent of Microsoft; we make no warranty, implied orotherwise, regarding these products' performance or reliability.
98 95 2.10 2.00 2.50
Properties

Article ID: 194178 - Last Review: 01/07/2015 07:26:50 - Revision: 2.4

  • Microsoft Windows 98 Standard Edition
  • Microsoft Windows 95
  • Microsoft Windows 95
  • Microsoft Windows 95
  • Microsoft Platform Software Development Kit-January 2000 Edition
  • kbnosurvey kbarchive kbqfe kbnetwork kbprb kbhotfixserver KB194178
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