XFOR: Rule Containing Multiple Clauses Only Functions Properly Once

This article was previously published under Q194228
This article has been archived. It is offered "as is" and will no longer be updated.
SYMPTOMS
When you create a rule for the Simple Mail Transfer Protocol (SMTP)service that contains multiple clauses, the rule may function properly thefirst time the server receives a message to which the rule applies;however, the rule does not function properly when the server receivesadditional messages to which the rule applies.
CAUSE
This problem occurs when the server modifies the rule the first time itreceives a message to which the rule applies. The server may replace thesemicolon (;) that separates the clauses with a colon (:), which preventsthe rule from functioning properly.
RESOLUTION
To resolve this problem, obtain the latest service pack for Windows NT 4.0 or Windows NT Server 4.0, Terminal Server Edition. For additional information, click the following article number to view the article in theMicrosoft Knowledge Base:
152734 How to Obtain the Latest Windows NT 4.0 Service Pack

STATUS
Microsoft has confirmed this to be a problem in Microsoft CommercialInternet System version 2.0. This problem was first corrected in Windows NT 4.0 Service Pack 4.0 and Windows NT Server 4.0, Terminal Server Edition Service Pack 4.
MORE INFORMATION
When you create a rule for the SMTP service that contains multipleclauses, the individual clauses are separated by a semicolon. If any ofthe clauses apply to a message, the action associated with the rule istaken.
XFOR
Properties

Article ID: 194228 - Last Review: 10/10/2013 22:30:40 - Revision: 4.1

Microsoft Windows NT Server 4.0, Terminal Server Edition, Microsoft Commercial Internet System 2.0

  • kbnosurvey kbarchive kbbug kbfix kbqfe KB194228
Feedback
ERROR: at System.Diagnostics.Process.Kill() at Microsoft.Support.SEOInfrastructureService.PhantomJS.PhantomJSRunner.WaitForExit(Process process, Int32 waitTime, StringBuilder dataBuilder, Boolean isTotalProcessTimeout)