LPD Job May Cause TCPSVCS to Hang

This article was previously published under Q197253
This article has been archived. It is offered "as is" and will no longer be updated.
Symptoms
After you sent a print job by using LPR to the TCP/IP Print Server, theTCP/IP Print server stops responding (hangs) and causes over 90 percent CPUusage in TCPSVCS.
Cause
This behavior occurs when the print job contains a value of 0x1B (ESC) in any of the following conditions:
  • At offset 0xFFF (4095).
  • As the very last character in a file.
  • As the only character in a file.
TCPSVCS has a routine to detect PCL or PostScript jobs, which goes into an infinite loop under these conditions.
Resolution

Windows NT 4.0

To resolve this problem, obtain the latest service pack for Windows NT 4.0 or the individual software update. For information on obtaining the latest service pack, please go to:
For information on obtaining the individual software update, contact Microsoft Product Support Services. For a complete list of Microsoft Product Support Services phone numbers and information on support costs, please go to the following address on the World Wide Web:

Terminal Server Edition

To resolve this problem, obtain the latest service pack for Windows NT Server 4.0, Terminal Server Edition. For additional information, click the following article number to view the article in theMicrosoft Knowledge Base:
152734 How to Obtain the Latest Windows NT 4.0 Service Pack
Status
Microsoft has confirmed this to be a problem in Windows NT version 4.0. This problem was first corrected in Windows NT 4.0 Service Pack 5 and Windows NT Server 4.0, Terminal Server Edition Service Pack 5.
4.00 tcpsvcs.exe
Properties

Article ID: 197253 - Last Review: 11/02/2013 20:11:00 - Revision: 3.0

  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows NT Server 4.0 Enterprise Edition
  • kbnosurvey kbarchive kbhotfixserver kbqfe kbbug kbfix KB197253
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