A user’s Office 365 email address unexpectedly contains an underscore character after directory synchronization

PROBLEM
After the Microsoft Azure Active Directory Sync Tool runs to sync your on-premises Active Directory environment to Azure Active Directory, a user’s Office 365 email address unexpectedly contains an underscore character "_". 
CAUSE
This occurs if the user account in your on-premises environment has a proxyaddresses attribute or mail attribute that contains one or more of the following special characters:
CharacterName
space character
`apostrophe
(opening parenthesis
)closing parenthesis
@at sign
'single quotation mark
&ampersand
\pipe
=equal sign
?question mark
/forward slash
%percent
In this scenario, after directory synchronization is run, the special character is replaced by an underscore character. Therefore, the user’s Office 365 email address contains an underscore character instead of the special character.
SOLUTION
Remove the special characters from the proxyaddresses attribute of the user account in the on-premises environment.
MORE INFORMATION
The characters that are listed in the Cause section are treated as special characters in Office 365. Use of any of these characters may cause issues such as service disruption.

Still need help? Go to the Office 365 Community website.
Properties

Article ID: 2001616 - Last Review: 07/09/2014 07:43:00 - Revision: 15.0

Microsoft Exchange Online, Office 365 Identity Management

  • o365 o365a o365062013 o365e o365m KB2001616
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