HOW TO: Preserve Formulas If You Save a Document As a Text File in Excel 2000

This article was previously published under Q213913
This article has been archived. It is offered "as is" and will no longer be updated.
For a Microsoft Excel 98 and earlier version of this article, see 153490.

IN THIS TASK

SUMMARY
In Microsoft Excel, you may occasionally want to save a document as atext file; for example, to fix corruption in the file.

Although an Excel file is saved as a text file, only the active sheet and the displayed values are saved. All formulas on the active sheet that are not displayed are discarded. This step-by-step article shows you to preserve those formulas that are otherwise discarded.

back to the top

Preserve Formulas If You Save As Text

You can preserve the formulas when you save the file as a text file if the formulas are displayed on the active sheet.

To display formulas in cells of the active sheet, use one of the following methods.

back to the top

Method 1: Keyboard

  1. Switch to the worksheet that you want.
  2. Press CTRL+ACCENT GRAVE (`).
back to the top

Method 2: Options Menu

  1. On the Tools menu, click Options.
  2. Click the View tab.
  3. In the Windows options section, click to select the Formulas check box.
  4. Click OK.
After the formulas are displayed in the cells, the file can be saved as atext file. This preserves both the values and formulas. When you reopenthe file, the Text Import Wizard prompts you for the original datatype and for you to indicate whether the file is fixed-width or delimited. If you select delimited for the file type and select Tab as the delimiter, the formulas are placed back in their respective cells, and the values that they produce are displayed.

The only way to preserve the formulas and values that were in individual cells on the original worksheet is to open the file as a tab-delimited file. All other methods force the text file to display its formulas when the Text Import Wizard is finished.

back to the top
corrupt corrupted corruption XL2000
Properties

Article ID: 213913 - Last Review: 10/14/2013 15:28:09 - Revision: 3.1

Microsoft Excel 2000 Standard Edition

  • kbnosurvey kbarchive kbhowto kbhowtomaster KB213913
Feedback