You are currently offline, waiting for your internet to reconnect

Can't open shared files or connect to shared printers

SYMPTOMS
You shared files or printers on a computer that is running Windows Vista or Windows 7. However, you cannot access the shared files or printers from another computer.

CAUSE
This problem can occur when file and printer sharing is blocked by the Windows Firewall on the computer where the files and printers are shared.

RESOLUTION

Diagnose and fix the problem automatically


Microsoft fix it banner
The Diagnose and fix Windows Firewall service problems automatically troubleshooter may automatically fix the problem described in this article.

This troubleshooter fixes many problems.



Learn more
Run now
The Diagnose and fix Windows Firewall service problems automatically troubleshooter may automatically fix the problem described in this article.
This troubleshooter fixes many problems.Learn moreRun now

MORE INFORMATION

How the MATS package works to fix this problem

  1. The MATS package scans your computer and detects if the following requirements are met:
    • The computer is running Windows XP, Windows Vista or Windows 7.
    • Windows Firewall is the default firewall program.
    • File and printer sharing is blocked in Windows Firewall.

  2. If all the requirements are met, the troubleshooter asks you if you want to allow file and printer sharing.
  3. If you click Yes, the troubleshooter allows file and printer sharing. If you click No, file and printer sharing remains blocked.

Other issues that the MATS package fixes


2288085 You get a security warning that the Windows Firewall is turned off
2271812 You can't turn on the Windows Firewall in the Security Center
2289618 You can’t use Remote Assistance to offer assistance
Properties

Article ID: 2292301 - Last Review: 06/28/2012 03:26:00 - Revision: 11.0

  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Ultimate
  • Windows 7 Enterprise
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Ultimate
  • kbprb kbtshoot kbsurveynew kbexpertisebeginner kbexpertiseinter kbmatsfixme KB2292301
Feedback