MS10-070: Description of the security update for the Microsoft .NET Framework 3.5 Service Pack 1 and .NET Framework 2.0 Service Pack 2 on Windows Server 2003 and on Windows XP

Support for Windows XP has ended

Microsoft ended support for Windows XP on April 8, 2014. This change has affected your software updates and security options. Learn what this means for you and how to stay protected.

Support for Windows Server 2003 ended on July 14, 2015

Microsoft ended support for Windows Server 2003 on July 14, 2015. This change has affected your software updates and security options. Learn what this means for you and how to stay protected.

INTRODUCTION
Microsoft has released security bulletin MS10-070. To view the complete security bulletin, visit one of the following Microsoft websites:

How to obtain help and support for this security update

Help installing updates: Support for Microsoft Update

Security solutions for IT professionals: TechNet Security Troubleshooting and Support

Help protect your computer that is running Windows from viruses and malware:Virus Solution and Security Center

Local support according to your country: International Support

MORE INFORMATION
For more information about how to configure legacy encryption mode in ASP.NET, click the following article number to view the article in the Microsoft Knowledge Base:
2425938 How to configure legacy encryption mode in ASP.NET

DOWNLOAD INFORMATION

The following file is available for download from the Microsoft Download Center:


DownloadDownload the package now.

Release Date: September 28, 2010

For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:
119591 How to obtain Microsoft support files from online services
Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file.

Prerequisites

To install this update, you must have Windows Installer 3.1 or a later version installed on the computer. To obtain the latest version of Windows Installer, visit the following Microsoft website:

Known issues and additional information about this security update

For more information about installation issues this security update or with the Microsoft .NET Framework 2.0 Service Pack 2, click the following article number to view the article in the Microsoft Knowledge Base:
2436257 Updates for the .NET Framework 2.0 SP2 and .NET Framework 3.0 SP2 may chain install other updates

2431728 Encrypted content in ASP.NET is not decrypted for a website that is deployed in a web farm

2431806 Updates for the .NET Framework 2.0 Service Pack 2, the .NET Framework 3.0 Service Pack 2, or the .NET Framework 3.5 Service Pack 1 may not correctly update files even when installation of the update succeeds

2431208 An update for the Microsoft .NET Framework may fail to install when the Microsoft .NET Framework 4 is installed and a restart is pending

923100 When you try to install an update for the .NET Framework 1.0, 1.1, 2.0, 3.0, or 3.5, you may receive Windows Update error code "0x643" or Windows Installer error code "1603"

923101 Error message when you try to install a security update for the .NET Framework 2.0 on a computer that is running Windows Server 2003 x64 Edition: "Error 1324. The folder 'Program Files' contains an invalid character"

2197146 Updates for the .NET Framework 3.5 Service Pack 1 and the .NET Framework 2.0 Service Pack 2 may cause the Microsoft Knowledge Base article number to appear instead of the full title of the update in the Add or Remove Programs item in Control Panel

2260913 Files in use or File Locks can Result in Framework Assembly Files being Deleted

2263996 Patching of Microsoft Framework can fail with Access is denied or File in Use error

Command-line switches for this update

For information about the various command-line switches that are supported by this update, see the Windows Installer command-line switches document.

For more information about Windows Installer, visit the Windows Installer MSDN website.

Restart requirement

You do not have to restart the system after you install this security update unless files that are being updated are locked or in use. However, this security update will cause all Internet Information Services (IIS)-related services to restart. These include the IISADMIN, W3SVC, FTP, and SMTP services. This behavior occurs because a base component for the .NET Framework includes instructions to restart these services. Therefore, every update to the product will execute the same instructions to restart these services.

Update removal information

To remove this security update, use the Add or Remove Programs item in Control Panel.
FILE INFORMATION
The English (United States) version of this software update installs files that have the attributes that are listed in the following tables. The dates and times for these files are listed in Coordinated Universal Time (UTC). The dates and times for these files on your local computer are displayed in your local time and with your current daylight saving time (DST) bias. Additionally, the dates and times may change when you perform certain operations on the files.

For x86-based systems

GDR files
File nameFile versionFile sizeDateTime
aspnet_wp.exe2.0.50727.361830,54422-Sep-201016:43
webengine.dll2.0.50727.3618435,02422-Sep-201016:43
System.Web.dll2.0.50727.36185,242,88022-Sep-201016:44
LDR files
File nameFile versionFile sizeDateTime
aspnet_wp.exe2.0.50727.505330,54422-Sep-201016:02
webengine.dll2.0.50727.5053436,04822-Sep-201016:02
System.Web.dll2.0.50727.50535,251,07222-Sep-201016:03

For x64-based systems

GDR files
File nameFile versionFile sizeDateTime
aspnet_wp.exe2.0.50727.361842,32022-Sep-201015:19
aspnet_wp.exe2.0.50727.361830,54422-Sep-201016:43
webengine.dll2.0.50727.3618743,76022-Sep-201015:19
webengine.dll2.0.50727.3618435,02422-Sep-201016:43
System.Web.dll2.0.50727.36185,251,07222-Sep-201015:23
System.Web.dll2.0.50727.36185,242,88022-Sep-201016:44
LDR files
File nameFile versionFile sizeDateTime
aspnet_wp.exe2.0.50727.505342,32022-Sep-201012:32
aspnet_wp.exe2.0.50727.505330,54422-Sep-201016:02
webengine.dll2.0.50727.5053745,29622-Sep-201012:32
webengine.dll2.0.50727.5053436,04822-Sep-201016:02
System.Web.dll2.0.50727.50535,259,26422-Sep-201012:37
System.Web.dll2.0.50727.50535,251,07222-Sep-201016:03

For IA-64-based systems

GDR files
File nameFile versionFile sizeDateTime
aspnet_wp.exe2.0.50727.361882,25622-Sep-201016:06
aspnet_wp.exe2.0.50727.361830,54422-Sep-201016:43
webengine.dll2.0.50727.36181,227,60022-Sep-201016:07
webengine.dll2.0.50727.3618435,02422-Sep-201016:43
System.Web.dll2.0.50727.36184,771,84022-Sep-201016:08
System.Web.dll2.0.50727.36185,242,88022-Sep-201016:44
LDR files
File nameFile versionFile sizeDateTime
aspnet_wp.exe2.0.50727.505382,25622-Sep-201014:15
aspnet_wp.exe2.0.50727.505330,54422-Sep-201016:02
webengine.dll2.0.50727.50531,231,18422-Sep-201014:16
webengine.dll2.0.50727.5053436,04822-Sep-201016:02
System.Web.dll2.0.50727.50534,780,03222-Sep-201014:17
System.Web.dll2.0.50727.50535,251,07222-Sep-201016:03
update security_patch security_update security bug flaw vulnerability malicious attacker exploit registry unauthenticated buffer overrun overflow specially-formed scope specially-crafted denial of service DoS TSE
Properties

Article ID: 2418241 - Last Review: 06/19/2012 02:35:00 - Revision: 6.0

Microsoft .NET Framework 3.5 Service Pack 1, Microsoft .NET Framework 2.0 Service Pack 2, Microsoft Windows Server 2003 Service Pack 2, Microsoft Windows XP Service Pack 3

  • atdownload kbbug kbexpertiseinter kbfix kbsecbulletin kbsecurity kbsecvulnerability KB2418241
Feedback