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Symptoms

You experience one or more of the following problems in Microsoft Windows Media Player.

Problem 1

When you try to stream audio or video from Microsoft Windows Media Services, you may receive an error message that resembles the following in Windows Media Player:

The specified protocol is unknown.

Note This problem does not occur when you play content that is stored on a local hard disk drive.

Problem 2

When you click the Network tab of the Windows Media Player Options menu, nothing happens.

Problem 3

On the Network tab of the Windows Media Player Options menu, the Streaming proxy settings protocol list is empty.






Cause

This problem may occur if one or more of the following conditions are true:

  • The Wmnetmgr.dll file is unregistered.



    Note The Wmnetmgr.dll file is located in the C:\Windows\System32 folder.

  • The Wmsdkns.xml file is corrupted.

    Note The Wmsdkns.xml file is the network namespace file for Windows Media Player.

  • The Wmsdkns.xml file has incorrect permissions.

Resolution

To resolve this problem, use one of the following methods.

Method 1

Register the Wmnetmgr.dll file by using an account that is in the Administrators group. To do this, follow these steps:

  1. Click Start , and then type regsvr32 wmnetmgr.dll in the search box.


  2. Right-click regsvr32 wmnetmgr.dll, and then click Run as administrator.


Method 2

Make sure that the user account that uses Windows Media Player has the necessary permissions for the Wmsdkns.xml file. To do this, follow these steps:


  1. Locate the following folder.

    Note You must enable the Show hidden files, folders, and drives option on your computer to show the folder. For more information, see the Show hidden files section.

    • In Windows 7

      C:\Users\UserName\AppData\Local\Microsoft\Windows Media\12.0

    • In Windows Vista

      C:\Users\UserName\AppData\Local\Microsoft\Windows Media\11.0

    • In Windows XP

      C:\Documents and Settings\UserName\Local Settings\Application Data\Microsoft\Windows Media\11.0

  2. Right-click the Wmsdkns.xml file, and then click Properties.


  3. Click the Security tab, and then select the user account that you use in the Group or user names list.



    The permissions of the user or group that you selected are shown at the bottom of the dialog box. Make sure that you have Modify permissions for the Wmsdkns.xml file.













    • If you logged on to the computer by using an account that does not have the necessary permissions, close the session, and then try again by using a system administrator account, or by using an account that has permissions to modify this file.

    • If you are not sure, contact your system administrator.

Method 3

Delete the Wmsdkns.xml file. After you delete it, Windows Media Player will re-create the Wmsdkns.xml file. To do this, follow these steps:

  1. Locate the following folder.

    Note You must enable the Show hidden files, folders, and drives option on your computer to show the folder. For more information, see the Show hidden files section.


    • In Windows 7

      C:\Users\UserName\AppData\Local\Microsoft\Windows Media\12.0

    • In Windows Vista

      C:\Users\UserName\AppData\Local\Microsoft\Windows Media\11.0

    • In Windows XP

      C:\Documents and Settings\UserName\Local Settings\Application Data\Microsoft\Windows Media\11.0

  2. Right-click the Wmsdkns.xml file, and then click Delete.


  3. In the confirmation window, click Yes.


  4. Restart the computer.

More Information

Show hidden files

To display hidden files and folders, follow these steps:

  1. In Windows Explorer, press the Alt key to show the menu bar, and then on the Tools menu, click Folder options.


  2. On the View tab, click to select Show hidden files, folders, and drives, and then click OK.




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