OL2000: How to Import and Export Text Data with Outlook

This article has been archived. It is offered "as is" and will no longer be updated.
Summary
This article describes how to use the Import and Export Wizard to import text data into Outlook, and export Outlook data to a text file.

Using a text file is helpful when the converters provided with Outlook donot directly match the format of the data you want to import. Most programs canexport and import text files, so you can often use a text file as a commonfile format for exporting and importing data.
More information
The Outlook Import and Export Wizard can import and export the followingtypes of text data:

  • Comma Separated Values (MS-DOS)
  • Comma Separated Values (Windows)
  • Tab Separated Values (MS-DOS)
  • Tab Separated Values (Windows)

MS-DOS or Windows

You should make the decision to use the MS-DOS or Windows converter basedon the text character set used in your data. ASCII is a character set usedby many MS-DOS programs, and ANSI is a character set used by many Windowsprograms. The main difference between ASCII and ANSI are the upper 128characters; the lower 128 characters are the same. The upper 128 charactersare often referred to as extended characters. ASCII extended charactersinclude line draw characters while ANSI extended characters includeinternational characters and publishing symbols.

Comma or Tab Delimiter

The character used to separate, or delimit each field in your data determinesif you use the comma or tab separated converter. If you open your data inMicrosoft Word 97 and see commas between each field, your data iscomma-separated (CSV). If you see a space between thefields, your data is either tab-separated, or uses a fixed width field.The Outlook tab-separated converter looks for a tab character betweenfields. In Word 97 you can select the Show/Hide option; tabs appear asarrows that point to the right, and space characters appear as small dots.

NOTE: Do not save your file as a Word document, since Word uses a differentfile format.

Before attempting to import data from a text file it is necessary toinspect the header record to assure that the items stored in the text filematch Outlook internal names. The header record is the first record in thetext file. It defines the way that the data is organized. If thesefields do not match, data will not be imported.

To find out what the standard Outlook field names are you can generate asample of these fields in Outlook.

To Generate a Sample of Outlook Fields

Before editing your data source, it may be helpful to generate a sampleof the fields used in Outlook. To generate the sample fields, follow thesesteps:
  1. If present, remove the current binary mapping file, "Comma Separated Values (Windows).adr" located in the Windows\Application folder. This procedure will rebuild this file.
  2. On the View menu, click Folder List if it is not already displayed.
  3. In the Folder List, right-click the Outlook folder you want to use, and on the shortcut menu, click New Folder.
  4. Give this temporary folder a name and click OK. You may delete this folder once the sample fields file is created.
  5. On the File menu, click Import And Export. Click Export to a File, and then click Next.
  6. In Create a file of Type, click Comma Separated Values (Windows), and then click Next.
  7. In Select folder to export from, click to select the folder you created in Step 2, and then click Next.
  8. In the Save exported file as, type a name for the file and click Browse, to select a folder to save the file in. Click OK to save the exported file, and then click Next, and then click Finish.
The resulting comma-separated values file contains the fields that Outlookuses for the folder you selected. Repeat this step as necessary for eachtype of data you want to import. While familiarizing yourself with theOutlook field labels, note that precise spelling is necessary. For example,when defining electronic mail addresses, Outlook uses the spelling, "e-mail."

Importing Text Data

To import data from a text file, follow these steps:
  1. On the File menu, click Import And Export.
  2. In Choose an action to perform, click Import from another program or file, and click Next.
  3. In Select file type to import from, click the file type that matches your data, and click Next.
  4. In File To Import, type the path and file name of the file you want to import, or click Browse to navigate to the file, and then click Next.
  5. In Select Destination Folder, click the folder you want to import to, and click Next.
  6. Confirm that the destination folder is correct, and then click Finish.

Exporting Text Data

  1. On the File menu, click Import And Export.
  2. In Choose an action to perform, click Export to a file, and click Next.
  3. In Create a file of type, click to select a format for the file you want export, and click Next.
  4. In Select folder to export from, click the folder you want to export, and click Next.
  5. In Save exported file as, type the path and file name for the file you want export, and click Next.
  6. Confirm the action and then click Finish.
OL2K convert
Properties

Article ID: 243476 - Last Review: 12/05/2015 16:13:47 - Revision: 4.0

Microsoft Outlook 2000 Standard Edition

  • kbnosurvey kbarchive kbexport kbhowto kbimport kbmigrate KB243476
Feedback