You are currently offline, waiting for your internet to reconnect

Updates for the .NET Framework 2.0 SP2 and for the .NET Framework 3.0 SP2 may chain-install other updates

Support for Windows XP has ended

Microsoft ended support for Windows XP on April 8, 2014. This change has affected your software updates and security options. Learn what this means for you and how to stay protected.

Support for Windows Server 2003 ended on July 14, 2015

Microsoft ended support for Windows Server 2003 on July 14, 2015. This change has affected your software updates and security options. Learn what this means for you and how to stay protected.

Support for Windows Vista Service Pack 1 (SP1) ends on July 12, 2011. To continue receiving security updates for Windows, make sure you're running Windows Vista with Service Pack 2 (SP2). For more information, refer to this Microsoft web page: Support is ending for some versions of Windows.
SYMPTOMS
When you install some updates for the Microsoft .NET Framework 2.0 Service Pack 2 (SP2) or for the Microsoft .NET Framework 3.0 SP2, these updates will chain-install additional updates. These additional updates have to be installed in order to satisfy new dependencies in certain .NET Framework components. 
MORE INFORMATION
When you install certain updates for the .NET Framework 2.0 SP2 or for the .NET Framework 3.0 SP2, these updates cause additional updates to be installed. This occurs because the Extended Protection Security Advisory introduced the new extended protection feature that includes new dependencies on newly introduced "types." This new feature consists of new functionality in the .NET Framework 2.0 SP2 and in the .NET Framework 3.0 SP2 feature layers. The new Windows Communication Foundation (WCF) feature in the .NET Framework 3.0 SP2 feature layer has a dependency on the corresponding new feature in the .NET Framework 2.0 SP2 feature layer and the new "type." The new ASP.NET feature in the .NET Framework 2.0 SP2 feature layer also has a new dependency on the new feature in System.Net (networking stack).

Updates for components of the .NET Framework are cumulative. Therefore, an update for the ASP.NET component that was released after the Extended Protection Security Advisory will always contain the new ASP.NET feature for extended protection. This new feature requires that the previously mentioned feature dependency (on the new "type") be met. Updates for the WCF and ASP.NET components will chain-install additional updates as required in order to satisfy this dependency. If this dependency is not met, you may experience the issue that is described in the following article in the Microsoft Knowledge Base: 
2262911 "Could not load type 'System.Security.Authentication.ExtendedProtection.ExtendedProtectionPolicy'" exception error after you install update 982167 or update 982168
  • In Windows XP and in Windows Server 2003, updates to the ASP.NET component in the .NET Framework 2.0 SP2 will also install the following update:
    980773 Description of the NCL update for the .NET Framework 3.5 Service Pack 1 and the .NET Framework 2.0 Service Pack 2 on Windows XP and on Windows Server 2003: June 8, 2010
  • In Windows Vista SP1 and in Windows Server 2008, updates to the ASP.NET component in the .NET Framework 2.0 SP2 will also install the following update:
    980843 Description of the NCL update for the .NET Framework 3.5 Service Pack 1 on Windows Vista Service Pack 1 and on Windows Server 2008 Service Pack 1: June 8, 2010
  • In Windows Vista SP2 and in Windows Server 2008, updates to the ASP.NET component in the .NET Framework 2.0 SP2 will also install the following update:
    980842 Description of the NCL update for the .NET Framework 3.5 Service Pack 1 on Windows Vista Service Pack 2 and on Windows Server 2008 Service Pack 2: June 8, 2010
  • In Windows XP and in Windows Server 2003, updates to the WCF component in the .NET Framework 3.0 SP2 will also install the following updates:  
    980773 Description of the NCL update for the .NET Framework 3.5 Service Pack 1 and the .NET Framework 2.0 Service Pack 2 on Windows XP and on Windows Server 2003: June 8, 2010
    976765 Description of the ASP.NET update for the .NET Framework 3.5 Service Pack 1 and the .NET Framework 2.0 Service Pack 2 on Windows XP and on Windows Server 2003: June 8, 2010
  • In Windows Vista SP1 and in Windows Server 2008, updates to the WCF component in the .NET Framework 3.0 SP2 will also install the following updates:
    980843 Description of the NCL update for the .NET Framework 3.5 Service Pack 1 on Windows Vista Service Pack 1 and on Windows Server 2008 Service Pack 1: June 8, 2010
    976767 Description of the ASP.NET update for the .NET Framework 3.5 Service Pack 1 on Windows Vista Service Pack 1 and on Windows Server 2008 Service Pack 1: June 8, 2010
  • In Windows Vista SP2 and in Windows Server 2008, updates to the WCF component in the .NET Framework 3.0 SP2 will also install the following updates:
    980842 Description of the NCL update for the .NET Framework 3.5 Service Pack 1 on Windows Vista Service Pack 2 and on Windows Server 2008 Service Pack 2: June 8, 2010
    976768 Description of the ASP.NET update for the .NET Framework 3.5 Service Pack 1 on Windows Vista Service Pack 2 and on Windows Server 2008 Service Pack 2: June 8, 2010
Properties

Article ID: 2436257 - Last Review: 06/10/2011 17:05:00 - Revision: 3.3

Microsoft .NET Framework 3.0 Service Pack 2, Microsoft .NET Framework 2.0 Service Pack 2, Windows 7 Enterprise, Windows 7 Home Basic, Windows 7 Home Premium, Windows 7 Professional, Windows 7 Ultimate, Windows Server 2008 R2 Standard, Windows Server 2008 R2 Enterprise, Windows Server 2008 R2 Datacenter, Windows Server 2008 Service Pack 2, Windows Server 2008 for Itanium-Based Systems, Windows Server 2008 Datacenter, Windows Server 2008 Enterprise, Windows Server 2008 Standard, Windows Web Server 2008, Windows Vista Service Pack 2, Windows Vista Service Pack 1, Microsoft Windows Server 2003 Service Pack 2, Microsoft Windows XP Service Pack 3

  • kbbug kbexpertiseinter kbsecbulletin kbsecurity kbsecvulnerability KB2436257
Feedback
dy>