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Lists with many lookup columns may not sync to SharePoint Workspace

Symptoms

You synchronize a SharePoint site to SharePoint Workspace. The workspace is created successfully, but one or more lists contain no data. All of these lists have multiple lookup columns. No error is displayed, however, error logs on the server contain the following error:

The query cannot be completed because the number of lookup columns it contains exceeds the lookup column threshold enforced by the administrator

Note A lookup column links to another list for possible field values. For example, "Product" might obtain possible values from a list of products and versions.

Cause

The unsynchronized lists include more lookup columns than allowed by the lookup column threshold. By default, SharePoint will only process 8 lookup columns in response to a query. The SharePoint server blocks queries that exceed this threshold rather than providing an incomplete response.

You may get this error for a list that appears to contain fewer lookup columns than the threshold allows. This is due to hidden lookup columns associated with certain data types. For example, if a list column is using theManaged Metadata content type, the list will include the hidden lookup columns TaxCatchAll and TaxCatchAllLabel, which perform lookups to a system taxonomy list. Because these columns do not appear in the column list, it may appear that you are below the lookup column threshold after you have exceeded it.

Resolution

A SharePoint site administrator must make one of the following changes:

  • (Recommended) Modify the list to have no more than the permitted number of lookup columns.
  • Increase the List view lookup threshold (See More Information)

After the list or threshold is changed, refresh the list by disconnecting and reconnecting it in SharePoint Workspace. To do this, follow these steps:

  1. In SharePoint Workspace, click to select the list or library.
  2. Click the Sync tab, click Change Sync Settings, and then clickDisconnect "list name" from Server.
  3. Wait for the list to be disconnected. Note  If you use the default display settings, it will move to theAvailable on Server section of the content list.
  4. Click to select the list, and then in the list pane, click Connect list name to Server.
More Information
A SharePoint administrator can change the List view lookup threshold in the Resource Throttling properties for the web application fromGeneral Settings in Central Administration. However, increasing this value is likely to cause performance problems. For more information on the SharePoint List view lookup threshold, see the entry in the "List and library limits" section on the following web site:  http://technet.microsoft.com/en-us/library/cc262787.aspx
Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.
Properties

Article ID: 2489707 - Last Review: 11/19/2014 18:52:00 - Revision: 9.0

Microsoft SharePoint Workspace 2010

  • KB2489707
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