Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

Symptoms

When you use Microsoft BizTalk Server to receive a compressed Applicability Statement 2 (AS2) message, an error message that resembles the following might be logged in the Application log:

Event Type: Error
Event Source: BizTalk Server 2009 EDI
Event Category: None
Event ID: 8133
Description:
The AS2 Decoder encountered an exception during processing. Details of the message and exception are as follows: AS2-From:"<AS2-From party>" AS2-To:"<AS2-To party>" MessageID:"<Message ID>" MessageType: "unknown" Exception:"Decompression failed while processing a compressed AS2 message. Error: Invalid Adler32 checksum encountered."

Note The event source value may vary depending on what version of BizTalk Server you use.

Cause

This issue occurs because the Adler32 checksum value is stored separately in two chunks when you receive a compressed AS2 message. Therefore, BizTalk Server does not read the value correctly.

Resolution

Cumulative update information

BizTalk Server 2006 R2
The hotfix that resolves this issue is included in cumulative update package 4 for BizTalk Server 2006 R2 SP1.

For more information about how to obtain the cumulative update package, click the following article number to view the article in the Microsoft Knowledge Base:


2682056Cumulative update package 4 for BizTalk Server 2006 R2 SP1

BizTalk Server 2010
For more information about how to obtain the cumulative update package, click the following article number to view the article in the Microsoft Knowledge Base:

2497789 Cumulative update package 1 for BizTalk 2010
BizTalk Server 2009
The hotfix that resolves this issue is included in cumulative update package 2 for BizTalk Server 2009.

For more information about how to obtain the cumulative update package, click the following article number to view the article in the Microsoft Knowledge Base:

2497794 Cumulative update package 2 for BizTalk Server 2009

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

References

For more information about BizTalk Server hotfixes, click the following article number to view the article in the Microsoft Knowledge Base:

2003907 Information about BizTalk Server hotfixes

For more information about the "Invalid Adler32 checksum encountered" error message, visit the following MSDN website:

General information about the "Invalid Adler32 checksum encountered" error message

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×