You are currently offline, waiting for your internet to reconnect

FIX: Password Fails to Meet Password Policy Requirements

This article was previously published under Q249294
BUG #: 18863 (SQLBUG_65)
BUG #: 56075 (SQLBUG_70)
When you install Microsoft SQL Server version 6.5 or 7.0 on a Microsoft Windows 2000-based computer, after the files are copied and the setup progresses a bit, the following error message appears:
The password does not meet the password policy requirements.
Check the minimum password length, password complexity and
password history requirements.
In SQL Server 6.5, the title of the dialog box is Configure SQL Executive, and in SQL 7.0, the title is Configure SQL Server Agent.

You can work around this problem by temporarily disabling strong password enforcement on your domain prior to installing SQL Server.
Microsoft has confirmed this to be a problem in SQL Server 7.0. This problem has been corrected in U.S. Service Pack 3 for Microsoft SQL Server 7.0. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
274799 INF: How to Obtain Service Pack 3 for Microsoft SQL Server 7.0 and Microsoft Data Engine (MSDE) 1.0
For more information, contact your primary support provider.
If you ignore this error, setup completes but users who do not log in as system administrator (SA) or members of the sysadmin role are not able to execute xp_cmdshell or run CmdExec job steps.

Article ID: 249294 - Last Review: 03/14/2006 10:32:11 - Revision: 5.1

  • Microsoft SQL Server 7.0 Standard Edition
  • Microsoft SQL Server 6.5 Standard Edition
  • kbbug kbfix KB249294