You are currently offline, waiting for your internet to reconnect

High CPU usage or a lengthy startup process occurs during WMI repository verification when a large WMI repository exists in Windows 7 or in Windows Server 2008 R2

On a computer that is running Windows 7 or Windows Server 2008 R2, you may encounter one of the following issues during Windows Management Instrumentation (WMI) repository verification:
  • The CPU usage of the Svchost.exe process that hosts the WMI service (Winmgmt) hits 100 percent. Additionally, high memory usage that is in relation to the large size of the WMI repository occurs.
  • The computer takes too much time for the startup process. For example, the computer takes too much time before you see the user logon interface or before you see the desktop after you log on the computer.
Note This issue usually occurs when the computer has a large WMI repository.
To resolve this issue, install the hotfix that is introduced in the following Microsoft Knowledge Base article:
2617858 Unexpectedly slow startup or logon process in Windows Server 2008 R2 or in Windows 7
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Article ID: 2505348 - Last Review: 11/15/2011 05:14:00 - Revision: 2.0

Windows 7 Enterprise, Windows 7 Home Basic, Windows 7 Home Premium, Windows 7 Professional, Windows 7 Starter, Windows 7 Ultimate, Windows Server 2008 R2 Datacenter, Windows Server 2008 R2 Enterprise, Windows Server 2008 R2 for Itanium-Based Systems, Windows Server 2008 R2 Foundation, Windows Server 2008 R2 Standard, Windows Web Server 2008 R2

  • kbfix kbexpertiseinter kbsurveynew KB2505348