The OCS2009-DBUpgrade.msi update package can be installed without an error message on an Office Communications Server 2007 R2 Standard Edition server that does not meet the minimum requirements

SYMPTOMS
Consider the following scenario:
  • You have a computer that has Microsoft Office Communications Server 2007 R2 Standard Edition installed.
  • The version of SQL Server 2005 Backward Compatibility Components on the computer does not meet the minimum requirements to install an update package for Office Communications Server 2007 R2 database (OCS2009-DBUpgrade.msi).
  • You install the OCS2009-DBUpgrade.msi update package on the computer.
In this scenario, the installation of the OCS2009-DBUpgrade.msi update package does not show error messages. However, the following error message is logged in the installation log file (QFE_DBSetup.log):

Updating SE server database stored procedures. This will take a while ...
cscript dbsetup.wsf /SqlServer:(local)\rtc /Role:se /Verbose
Microsoft (R) Windows Script Host Version 5.7
Copyright (C) Microsoft Corporation. All rights reserved.

Installed SQL Server 2005 Backward Compatibility version is 8.05.1054
Error: SQL Server 2005 Backward Compatibility is not installed or its version is not high enough. SQL Server 2005 Backward Compatibility SP2 or higher must be installed.
RESOLUTION
To resolve this issue, install the following cumulative update:
2512777 Description of the cumulative update package for Office Communications Server 2007 R2 database: March, 2011

STATUS
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
Eigenschaften

Artikelnummer: 2512776 – Letzte Überarbeitung: 03/10/2011 22:53:00 – Revision: 1.0

Microsoft Office Communications Server 2007 R2 Standard Edition

  • kbqfe kbfix kbsurveynew kbexpertiseinter kbhotfixrollup KB2512776
Feedback