Error message when installing RSAT: 'This update is not applicable to your computer'

SYMPTOMS
When installing the Remote Server Administration Tools for Windows 7 (RSAT), you may receive the following error message:

"This update is not applicable to your computer"

CAUSE
This error will occur if you attempt to install RSAT after installing Service Pack 1 for Windows 7. The RSAT tools are designed for the RTM version of Windows 7 and are not compatible with Service Pack 1. However, Service Pack 1 includes updated components for RSAT, so if RSAT is installed before Service Pack 1, the issue will not occur and the components will be updated automatically.
RESOLUTION
Install RSAT tools before installing Service Pack 1 for Windows 7. If Service Pack 1 for Windows 7 is already installed, it can be uninstalled and then reinstalled after the RSAT tools are installed.
MORE INFORMATION
Microsoft has confirmed this to be by design, as RSAT was designed for Windows 7 RTM version. A newer version of RSAT is slated to be released in the future. More information on the RSAT tools is available at the following web site:

http://www.microsoft.com/downloads/en/details.aspx?FamilyID=7d2f6ad7-656b-4313-a005-4e344e43997d&displaylang=en
RSAT install setup sp1
Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.
Properties

Article ID: 2517239 - Last Review: 03/01/2011 20:27:00 - Revision: 1.0

Windows 7 Enterprise, Windows 7 Home Basic, Windows 7 Home Premium, Windows 7 Professional, Windows 7 Service Pack 1, Windows 7 Ultimate

  • KB2517239
Feedback