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Error Message: Acrobat Reader Failed to Update the System Registry

This article was previously published under Q255130
SYMPTOMS
When you try to run Adobe Acrobat Reader version 4.0, you may receive the following error message:
Acrobat Reader

Failed to update the system registry.
Please try using REGEDIT.
CAUSE
This issue can occur if the following registry keys do not grant the Set Value permission to the current user:
HKEY_CLASSES_ROOT\AcroExch.Document
HKEY_CLASSES_ROOT\CLSID\{B801CA65-A1FC-11D0-85AD-444553540000}
The Adobe Acrobat Reader 4.0 program attempts to write to these registry keys when it starts and generates an error message if it is unable to do so. These registry keys are not generally "writeable" in a secured environment.
RESOLUTION
To resolve this issue, grant all users the "Set Value" permission:

WARNING: Granting all users the "Set Value" permission on a shared registry key may not be permitted by your system administrator, and/or your local security policies. Because of this, please use caution when you use the following procedure.
  1. Log on to your computer as an administrator.
  2. Use Regedt32.exe to view the following registry keys:
    HKEY_CLASSES_ROOT\AcroExch.Document
    HKEY_CLASSES_ROOT\CLSID\{B801CA65-A1FC-11D0-85AD-444553540000}
    Grant all users (everyone) the "Set Value" permission on each of these shared registry keys.
STATUS
Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.
MORE INFORMATION
The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.
Properties

Article ID: 255130 - Last Review: 10/31/2003 17:43:00 - Revision: 3.0

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • kberrmsg kbprb kb3rdparty KB255130
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