Event IDs 9519 and 8012 When Starting the Information Store

This article was previously published under Q258529
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SYMPTOMS
When you attempt to start the Exchange information store service, you may receive the following event in the Event Viewer application log:
Event Type: Error
Event Source: MSExchangeIS
Event Category: General
Event ID: 9519
Date: 03/28/2000
Time: 3:30:48 PM
User: N/A
Computer: SERVERNAME
Description:
Error 0xfffffde0 starting database /O=Organization/OU=AdministrativeGroup/cn=Configuration/cn=Servers/cn=SERVERNAME/cn=Microsoft Private MDB on the Microsoft Exchange Information Store.

Event Type: Error
Event Source: NTBackup
Event Category: None
Event ID: 8012
Date: 03/28/2000
Time: 3:12:58 PM
User: N/A
Computer: SERVERNAME
Description:
The 'Microsoft Information Store' returned 'The restore environment information isn't found.
' from a call to 'HrESERestoreReopen()' additional data 'SERVERNAME'
CAUSE
In the first event, Error 0xfffffde0 refers to JET_errSoftRecoveryOnBackupDatabase. This means that the Storage Group attempted to restart after a crash, and that the database was restored (but not hard-recovered). In other words, the hard recovery log file replay process was not successfully completed, or was possibly interrupted.

The second event description indicates that the proper Restore.env file could not be located.

This issue can occur if you restore two Storage Groups in the same backup session, and enter the same log file replay location.
RESOLUTION
Only restore one Storage Group at a time, or if you are restoring multiple Storage Groups, be sure to enter unique paths for the temporary location for log and patch files.
MORE INFORMATION
For example, using Microsoft Windows 2000 Backup utility, Ntbackup.exe, you restore a Storage Group (First Storage Group), and enter C:\Temp as the folder for the temporary location for log and patch files, but do not click Last Restore Log Set. This restores the databases to their original location, the log files to the C:\Temp folder, and writes the Restore.env file to the C:\Temp folder as well. Because you did not click Last Restore Log Set, log file replay (hard recovery) will not begin automatically.

If you restore a different Storage Group (Second Storage Group), and enter C:\Temp as the folder for the temporary location for log and patch files, and you then click Last Restore Log Set, this restores the databases to their original location, but overwrites the previous restore session's log files and the Restore.env file.

When hard recovery begins on both Storage Groups (when the information store service is started), the hard recovery process will fail for the First Storage Group, because its log files and Restore.env file are overwritten by the restore process of the Second Storage Group.
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Article ID: 258529 - Last Review: 12/05/2015 19:24:51 - Revision: 3.5

Microsoft Exchange Server 2003 Enterprise Edition, Microsoft Exchange Server 2003 Standard Edition, Microsoft Exchange 2000 Server Standard Edition, Microsoft Windows Small Business Server 2003 Premium Edition, Microsoft Windows Small Business Server 2003 Standard Edition

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