When you use Microsoft Dynamics CRM 2011, Internet Explorer 9 may reload and cause CRM to crash

Symptoms
When you open or close Microsoft Dynamics CRM 2011 records, the CRM application may crash and Internet Explorer reloads. A script error may also occur, similar to below:

<Message>Object doesn't support this property or method</Message>

or

<Message>'lookupstyle' is null or not an object</Message>


Please see More Information for additional script detail
Cause
This is caused by the Internet Explorer 9 Hang Resistance Feature. The Hang Resistance feature is enabled by default in Windows Internet Explorer 9. Setting the HangRecovery value to 0 disables this feature; setting it to 1 enables it.
Resolution
As a workaround, to have us disable the Hang Resistance feature for you, go to the "Here's an easy fix" section. If you prefer to disable the Hang Resistance feature yourself, go to the "Let me fix it myself" section.

Here's an easy fix

To disable the Hang Resistance feature automatically, click the Download button. In the File Download dialog box, click Run or Open, and then follow the steps in the easy fix wizard.
  • This wizard may be in English only. However, the automatic fix also works for other language versions of Windows.
  • If you’re not on the computer that has the problem, save the easy fix solution to a flash drive or a CD, and then run it on the computer that has the problem.

Let me fix it myself

Easy fix 50893 

As a workaround, use the steps below to disable this feature:

1. Point to the Start menu, click Run, and then type regedit.
2. Navigate to HKEY_Current_User\Software\Microsoft\Internet Explorer\Main
3. Right-click Main, and then select new DWORD (32-bit) Value
4. Enter HangRecovery as the name.
5. The default value will be 0.

Did this fix the problem?

Check whether the problem is fixed. If the problem is fixed, you are finished with this section. If the problem is not fixed, you can contact support.
More information
A webpage or an ActiveX control that is hosted on a webpage may stop receiving the focus intermittently in Internet Explorer 9
http://support.microsoft.com/kb/2633864


A web page may fail to get focus in Windows Internet Explorer 9
http://support.microsoft.com/kb/2600156


<CrmScriptErrorReport>
<ReportVersion>1.0</ReportVersion>
<ScriptErrorDetails>
<Message>Object doesn't support this property or method</Message>
<Line>53</Line>
<URL>/_static/_forms/controls/form.crm.htc?ver=1272624968</URL>
<PageURL>/userdefined/edit.aspx?_gridType=1&etc=1&id=%7b882F4C68-14EE-E011-BDA0-00155D9D3D22%7d&pagemode=iframe&rskey=759356843&sitemappath=Workplace%7cMyWork%7cnav_dashboards</PageURL>
<Function>BuildXml(bValidate,bClose,bBuildFullXml,bValidateForWorkflow,bIsDirtyCheck)</Function>
<CallStack>
<Function>BuildXml(bValidate,bClose,bBuildFullXml,bValidateForWorkflow,bIsDirtyCheck)</Function>
<Function>IsReadyToClose()</Function>
<Function>Close(oEvent)</Function>
</CallStack>


or


<CrmScriptErrorReport>
<ReportVersion>1.0</ReportVersion>
<ScriptErrorDetails>
<Message>'lookupstyle' is null or not an object</Message>
<Line>73</Line>
<URL>/_static/_forms/controls/img.lu.htc?ver=1272624968</URL>
<PageURL>/userdefined/edit.aspx?_gridType=1&etc=1&id=%7b882F4C68-14EE-E011-BDA0-00155D9D3D22%7d&pagemode=iframe&rskey=759356843&sitemappath=Workplace%7cMyWork%7cnav_dashboards</PageURL>
<Function>getDataXml(sAttributeName)</Function>
<CallStack>
<Function>getDataXml(sAttributeName)</Function>
<Function>BuildXml(bValidate,bClose,bBuildFullXml,bValidateForWorkflow,bIsDirtyCheck)</Function>
<Function>IsReadyToClose()</Function>
<Function>Close(oEvent)</Function>
</CallStack>

fixit fix it fixme
Properties

Article ID: 2698959 - Last Review: 09/28/2015 02:25:00 - Revision: 5.0

Microsoft Dynamics CRM 2011

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