Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

Symptoms

Assume that you install Microsoft BizTalk Server 2010 on a computer. Then, you run the "DTA Archive and Purge SQL Server Agent" job to archive and delete tracking data from the BizTalk Tracking (BizTalkDTADb) database. In this situation, orphaned rows are created in the dta_ServiceInstanceExceptions table of the BizTalkDTADb database. The issue typically occurs when a message instance is resumed and then fails again. This behavior generates multiple rows that have the same uidServiceInstanceId and uidActivityId variables in the dta_ServiceInstanceExceptions table.

Notes

  • The orphaned rows are identified by Monitor BizTalk Server (BizTalkMgmtDb) as orphaned DTA service instance exceptions.

  • The orphaned rows are in the dta_ServiceInstanceExceptions table and have no corresponding rows in dta_ServiceInstances table.

  • The orphaned rows are never cleaned up.

Cause

This issue occurs because of an error in a stored procedure that is used by the "DTA Archive and Purge SQL Server Agent" job.

Resolution

Cumulative update information

BizTalk Server 2010

The hotfix that resolves this issue is included in cumulative update package 5 for BizTalk Server 2010.

For more information about how to obtain the cumulative update package, click the following article number to view the article in the Microsoft Knowledge Base:

2689458 Cumulative update package 5 for BizTalk Server 2010

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about how to archive and delete the BizTalk Tracking database checklist, go to the following MSDN website:

General information about how to archive and purge the BizTalk Tracking database checklistFor more information about how to manually delete data from the BizTalk Tracking database, go to the following MSDN website:

How to manually purge data from the BizTalk Tracking databaseFor information about the service packs and cumulative update list for BizTalk Server, click the following article number to view the article in the Microsoft Knowledge Base:

2555976 Service pack and cumulative update list for BizTalk Server For more information about BizTalk hotfixes and service pack support, click the following article number to view the article in the Microsoft Knowledge Base:

2003907 Information about BizTalk hotfixes and service pack support

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×