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Symptoms

Consider the following scenario:

  • You have a Unified Messaging-enabled mailbox in a Microsoft Exchange Server 2010 environment.

  • The mailbox contains more than 51 voice messages.

  • The oldest 50 voice messages are marked as read, and there is more than one unread voice message in the mailbox. For example, there are 53 voice messages in the mailbox. The oldest 50 voice messages are marked as read, and the other three voice messages are marked as unread.

  • The play order for the unread voice messages is set to From oldest to newest in Microsoft Outlook Web App.

  • You call into Outlook Voice Access to listen to the unread voice messages.

In this scenario, Outlook Voice Access does not play the voice messages, and UMWorkerProcess.exe consumes memory at an exponential rate in Windows Task Manager. Additionally, when you end the call, UMWorkerProcess.exe stops using large amounts of memory. However, UMWorkerProcess.exe does not release the memory that it already consumed. When you call into Outlook Voice Access again, UMWorkerProcess.exe continues to consume large amounts of memory.

Note To release the memory that UMWorkerProcess.exe consumed, the administrator has to kill the process or restart the Unified Messaging service.


Cause

This issue occurs because the logic for populating voice messages from a mailbox is incorrect.


Resolution

To resolve this issue, install the following update rollup:

2685289 Description of Update Rollup 3 for Exchange Server 2010 Service Pack 2

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about Exchange Server 2010 Unified Messaging, go to the following Microsoft website:

Overview of Unified Messaging

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