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Symptoms

Consider the following scenario:

  • You install update 2571543 or a later cumulative update for Lync 2010 on a Lync 2010 client in a Lync Server 2010 environment.

  • You deploy the federation feature or multiple Front End pools in the environment.

  • A user who has more than 100 contacts in the federated environment or in a different Front End pool signs in to Lync 2010.

In this scenario, the "Presence unknown" status is displayed for many of the contacts in Lync 2010. However, the status of the contacts is updated after 30 minutes.

Note When the user sends an instant message to the affected contacts, the status information is updated immediately.

Cause

This issue occurs because update 2571543 changes the way subscription requests are sent in Lync 2010. After you apply update 2571543 or a later cumulative update for Lync 2010 that fixes the issues that are documented in update 2571543, failed subscription requests are sent again within 30 minutes.

Notes

  • Update 2571543 changes the way subscription requests are sent. This change precents an issue that occurs when too many presence subscription requests are sent for federated contacts or for contacts that are located in another Front End pool.

  • After you install this update, subscription requests are added to a queue before they are sent.


Resolution

To resolve the issue, install the following cumulative update.

2737155 Description of the cumulative update package for Lync 2010: October 2012
Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:

322756 How to back up and restore the registry in WindowsAfter you install the hotfix package, to have us enable the hotfix for you, go to the "Fix it for me" section. If you prefer to enable the hotfix yourself, go to the "Let me fix it myself" section.

Fix it for me



To enable the hotfix automatically, click the Fix it button or link. Then click Run in the File Download dialog box, and follow the steps in the Fix it wizard.




Notes

  • This wizard may be in English only. However, the automatic fix also works for other language versions of Windows.

  • If you are not on the computer that has the problem, save the Fix it solution to a flash drive or a CD and then run it on the computer that has the problem.

  • We would appreciate your feedback. To provide feedback or to report any issues with this solution, please leave a comment on the "Fix it for me" blog or send us an email message.


Let me fix it myself

After you install the hotfix package, follow these steps to enable the hotfix:

  1. Open Registry Editor. To do this, click Start, type regedit in the Start Search box, and then press Enter.

  2. Locate and then click the following registry keys:
    HKEY LOCAL MACHINE\Software\Policies\Microsoft\Communicator

  3. On the Edit menu, point to New, and then click DWORD (32 bit) Value.

  4. Type DisableDropTransactionOnSeqNumLimit, and then press Enter.

  5. On the Edit menu, click Modify.

  6. In the Value data box, type 1, and then click OK.

  7. Exit Registry Editor.


More Information

For more information about cumulative update packages for Lync 2010, click the following article number to view the article in the Microsoft Knowledge Base:

2571543 Description of the cumulative update package for Lync 2010: July 2011

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