Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

Symptoms

Consider the following scenario:

  • You have a computer that is running a multilingual version of Windows RT, Windows 8, or Windows Server 2012.

  • You configure the computer to use your local language during the Out of Box Experience (OOBE) process.

  • You use the "Refresh your PC" feature to refresh your computer.

In this scenario, you experience one of the following issues:

  • You cannot start any console programs (for example, Cmd.exe or Powershell.exe). Additionally, you receive the follow error message:

    0xc0000142 (STATUS_DLL_INIT_FAILED)

  • The fonts in all console programs become too small to read.

Notes

  • This issue occurs when you select one of the following languages:

    • Central Kurdish (Iraq)

    • Sindhi (Islamic Republic of Pakistan)

    • Chinese (Simplified, PRC)

    • Chinese (Traditional, Taiwan)

    • Chinese (Traditional, Hong Kong S.A.R.)

  • If the OEM manufacturer changes the dots per inch (dpi) setting in the Windows Setup unattended answer file, you cannot start any console programs.

  • If the OEM manufacturer does not change the dpi setting in the unattended answer file, the fonts in all console programs become too small to read.

Cause

This issue occurs because certain registry settings are not migrated when you refresh the computer.

Workaround

To work around this issue, follow these steps:

  1. Swipe in from the right edge of the screen, and then tap Search. Or, if you are using a mouse, point to the lower-right corner of the screen, and then click Search.

  2. Select or tap Settings.

  3. Type Change date, time or number formats in the search box to locate the option to change the regional settings.

  4. In the Region dialog box, click the Administrative tab, and then click Change system locale under Language for non-Unicode programs.

    Note If you are prompted for an administrator password or for confirmation, type the password or provide confirmation.

  5. Set the current system locale to English (United States).

  6. Select or tap OK and Apply as required to confirm the changes.

  7. Restart the computer, and then repeat step 1 to step 4.

  8. In the Region dialog box, click Change System Locale, and then select the language that you want to use on the computer.

  9. Select or tap OK and Apply as required to confirm the changes.

  10. Restart the computer.

More Information

Registry keys that are related to this issue

  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\GRE_Initialize

  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Console

  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FontAssoc

  • HKEY_LOCAL_MACHINE\SOFTWARE\MICROSOFT\Windows NT\CurrentVersion\FontLink

  • HKEY_LOCAL_MACHINE\SOFTWARE\MICROSOFT\Windows NT\CurrentVersion\FontMapper

  • HKEY_LOCAL_MACHINE\SOFTWARE\MICROSOFT\Windows NT\CurrentVersion\LanguagePack\SurrogateFallback

Resolution

Update information

How to obtain this update

Windows Update

This update is available from Windows Update.

Microsoft Download Center

The following files are available for download from the Microsoft Download Center:

Operating system

Update

All supported x86-based versions of Windows 8

Download Download the package now.

All supported x64-based versions of Windows 8

Download Download the package now.

All supported x64-based versions of Windows Server 2012

Download Download the package now.

For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:

119591 How to obtain Microsoft support files from online services Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file.

Prerequisites

To apply this update, you must be running Windows RT, Windows 8, or Windows Server 2012.

Registry information

To apply this update, you do not have to make any changes to the registry.

Restart requirement

You do not have to restart the computer after you apply this update.

Update replacement information

This update does not replace a previously released update.

The global version of this update installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows RT, Windows 8, and Windows Server 2012 file information notes

  • The files that apply to a specific product, milestone (RTM,SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:

    Version

    Product

    Milestone

    Service branch

    6.2.920 0.16 xxx

    Windows RT, Windows 8, and Windows Server 2012

    RTM

    GDR

  • GDR service branches contain only those fixes that are widely released to address widespread, critical issues. LDR service branches contain hotfixes in addition to widely released fixes.

  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows RT, Windows 8, and Windows Server 2012" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.

For Windows RT

File name

File version

File size

Date

Time

Platform

Reseteng.dll

6.2.9200.16480

809,192

15-Dec-2012

04:13

Not applicable

Resetengmig.dll

6.2.9200.16450

797,928

03-Nov-2012

06:57

Not applicable

Srms.dat

Not applicable

43,882

17-Jul-2012

03:01

Not applicable

Sysreset.exe

6.1.7782.0

117,248

03-Nov-2012

04:27

Not applicable

Reagent.dll

6.2.9200.16480

346,344

15-Dec-2012

04:13

Not applicable

Reagent.xml

Not applicable

856

06-Jul-2012

20:25

Not applicable

For all supported x86-based versions of Windows 8

File name

File version

File size

Date

Time

Platform

Reseteng.dll

6.2.9200.16480

847,360

15-Dec-2012

04:55

x86

Resetengmig.dll

6.2.9200.16450

733,184

03-Nov-2012

05:25

x86

Srms.dat

Not applicable

43,882

17-Jul-2012

03:12

Not applicable

Sysreset.exe

6.1.7782.0

117,248

03-Nov-2012

05:26

x86

Reagent.dll

6.2.9200.16480

375,808

15-Dec-2012

04:55

x86

Reagent.xml

Not applicable

856

06-Jul-2012

19:51

Not applicable

For all supported x64-based versions of Windows 8 and of Windows Server 2012

File name

File version

File size

Date

Time

Platform

Reseteng.dll

6.2.9200.16480

1,010,688

15-Dec-2012

04:55

x64

Resetengmig.dll

6.2.9200.16450

945,152

03-Nov-2012

05:25

x64

Srms.dat

Not applicable

43,882

17-Jul-2012

03:01

Not applicable

Sysreset.exe

6.1.7782.0

132,096

03-Nov-2012

05:26

x64

Reagent.dll

6.2.9200.16480

443,392

15-Dec-2012

04:55

x64

Reagent.xml

Not applicable

856

06-Jul-2012

20:28

Not applicable


Additional file information for Windows RT, Windows 8, and Windows Server 2012

Additional files for Windows RT

File name

Arm_microsoft-windows-sysreset_31bf3856ad364e35_6.2.9200.16480_none_38cb9a084fde7410.manifest

File version

Not applicable

File size

5,052

Date (UTC)

15-Dec-2012

Time (UTC)

20:01

Platform

Not applicable

File name

Arm_microsoft-windows-winre-recoveryagent_31bf3856ad364e35_6.2.9200.16480_none_b7761cdb414af55a.manifest

File version

Not applicable

File size

4,393

Date (UTC)

15-Dec-2012

Time (UTC)

04:23

Platform

Not applicable

Additional files for all supported x86-based versions of Windows 8

File name

X86_microsoft-windows-sysreset_31bf3856ad364e35_6.2.9200.16480_none_38c927b04fe1554a.manifest

File version

Not applicable

File size

5,052

Date (UTC)

15-Dec-2012

Time (UTC)

20:04

Platform

Not applicable

File name

X86_microsoft-windows-winre-recoveryagent_31bf3856ad364e35_6.2.9200.16480_none_b773aa83414dd694.manifest

File version

Not applicable

File size

4,393

Date (UTC)

15-Dec-2012

Time (UTC)

05:50

Platform

Not applicable

Additional files for all supported x64-based versions of Windows 8 and Windows Server 2012

File name

Amd64_microsoft-windows-sysreset_31bf3856ad364e35_6.2.9200.16480_none_94e7c334083ec680.manifest

File version

Not applicable

File size

5,056

Date (UTC)

15-Dec-2012

Time (UTC)

20:07

Platform

Not applicable

File name

Amd64_microsoft-windows-winre-recoveryagent_31bf3856ad364e35_6.2.9200.16480_none_13924606f9ab47ca.manifest

File version

Not applicable

File size

4,397

Date (UTC)

15-Dec-2012

Time (UTC)

07:34

Platform

Not applicable


For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×