FIX: Incorrect Version of Dapi.dll Installed from Exchange 2000 CD for Exchange 5.5 Management Tools

This article was previously published under Q280136
This article has been archived. It is offered "as is" and will no longer be updated.
The Exchange 2000 CD provides the option to install the Exchange 5.5 Management tools. If you choose this option, the Exchange 2000 version of the dynamic-link libraries (Dlls) for the Directory Application Programming Interface (DAPI) version 6.0.4417 are installed. This version of the DAPI DLLs is not supported programmatically against an Exchange 5.x Server. If you use DAPI to access an Exchange 5.x directory, you should use the DAPI DLLs that ship with Exchange 5.x.

For additional information, see the "References" section below.
To resolve this problem, obtain the latest service pack for Microsoft Exchange 2000 Server. For additional information, click the following article number to view the article in theMicrosoft Knowledge Base:
301378 XGEN: How to Obtain the Latest Exchange 2000 Server Service Pack
Microsoft has confirmed that this is a bug in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Microsoft Exchange 2000 Server Service Pack 1.
For additional information on how to install DAPI, click the article numbers below to view the articles in the Microsoft Knowledge Base:
169551 INFO: Items Required to Use DAPI
252886 INFO: Exchange 2000 Does Not Support Directory API

Article ID: 280136 - Last Review: 10/26/2013 07:22:00 - Revision: 4.0

Microsoft Exchange 2000 Server Standard Edition, Microsoft Exchange Server 5.0 Standard Edition, Microsoft Exchange Server 5.5 Standard Edition

  • kbnosurvey kbarchive kbbug kbfix kbmsg KB280136