Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

Symptoms

On a Windows Server 2012-based computer that has the Remote Desktop Services (RDS) role installed, the following issues occur.

Issue 1

Assume that you have the Remote Desktop Services (RDS) role installed on a computer that is running Windows Server 2012. You run an application that uses Windows Terminal Server virtual channel APIs (such as the WtsVirtualChannelOpen and WtsVirtualChannelClose APIs) to create and use virtual channels in a Remote Desktop Protocol (RDP) session. In this situation, RDP static virtual channels do not work. Additionally, Virtual channel communication fails in the RDP session if you do not reestablish the connection.

Notes

  • This issue does not affect other running RDP sessions.

  • This issue can appear in different ways. For example, when you schedule several print jobs in a Remote Desktop Protocol session, the print jobs are deleted.

Issue 2

Consider the following scenario:

  • You have the Remote Desktop Services (RDS) role installed on a Windows Server 2012-based computer.

  • You run an application that uses Windows Terminal Server virtual channel APIs (such as the WtsVirtualChannelOpen and WtsVirtualChannelClose APIs) to create and use virtual channels in a Remote Desktop Protocol (RDP) session.

  • The application tries to open a static virtual channel by using a channel name that does not exist.

In this scenario, the operation that opens the static virtual channel stalls for 10 seconds when the system tries to open the nonexistent virtual channel again.

Cause

Cause of Issue 1

This issue occurs because of a race condition that occurs when the system cannot open a static virtual channel.

Cause of Issue 2

This issue occurs because the channel is not closed when the channel receives an error when the virtual channel is created.

Resolution

Hotfix information


A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2012.

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows Server 2012 file information notesImportant Windows 8 hotfixes and Windows Server 2012 hotfixes are included in the same packages. However, only "Windows 8" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 8" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.

  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:

    Version

    Product

    Milestone

    Service branch

    6.2.920 0.16 xxx

    Windows Server 2012

    RTM

    GDR

    6.2.920 0.20 xxx

    Windows Server 2012

    RTM

    LDR

  • GDR service branches contain only those fixes that are widely released to address widespread, critical issues. LDR service branches contain hotfixes in addition to widely released fixes.

  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2012" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.

For all supported x64-based versions of Windows Server 2012

File name

File version

File size

Date

Time

Platform

Rdpcorets.dll

6.2.9200.16499

3,246,592

13-Jan-2013

23:24

x64

Rdpudd.dll

6.2.9200.16434

235,520

12-Oct-2012

05:50

x64

Rdpvideominiport.sys

6.2.9200.16434

27,880

12-Oct-2012

08:08

x64

Rfxvmt.dll

6.2.9200.16434

36,352

12-Oct-2012

06:14

x64

Rdpcorets.dll

6.2.9200.20606

3,246,080

13-Jan-2013

23:21

x64

Rdpudd.dll

6.2.9200.16384

235,520

26-Jul-2012

02:30

x64

Rdpvideominiport.sys

6.2.9200.16384

27,888

26-Jul-2012

03:17

x64

Rfxvmt.dll

6.2.9200.16384

36,352

26-Jul-2012

03:07

x64



Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about the static virtual channel, go to the following Microsoft website:

General information about static and dynamic virtual channels For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information for Windows Server 2012

Additional files for all supported x64-based versions of Windows Server 2012

File name

Amd64_3f7edad328636aff622707828a6e41af_31bf3856ad364e35_6.2.9200.20607_none_dd2aafee74d49dfc.manifest

File version

Not applicable

File size

729

Date (UTC)

14-Jan-2013

Time (UTC)

18:36

Platform

Not applicable

File name

Amd64_d42324a2d55189f4b91da8bf9b44c405_31bf3856ad364e35_6.2.9200.16500_none_cc71fe0a6f8a71fe.manifest

File version

Not applicable

File size

729

Date (UTC)

14-Jan-2013

Time (UTC)

18:36

Platform

Not applicable

File name

Amd64_microsoft-windows-r..s-regkeys-component_31bf3856ad364e35_6.2.9200.16500_none_88aa540c915617f2.manifest

File version

Not applicable

File size

13,555

Date (UTC)

14-Jan-2013

Time (UTC)

18:37

Platform

Not applicable

File name

Amd64_microsoft-windows-r..s-regkeys-component_31bf3856ad364e35_6.2.9200.20607_none_893af2ddaa6d691d.manifest

File version

Not applicable

File size

13,555

Date (UTC)

14-Jan-2013

Time (UTC)

18:37

Platform

Not applicable



Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×