Opportunity line items don't automatically calculate in Microsoft Dynamics CRM Online after applying the December 2012 Service Update

This article provides a solution to an issue where opportunity line items don't automatically calculate in Microsoft Dynamics CRM Online after applying the December 2012 Service Update.

Applies to:   Microsoft Dynamics CRM 2011
Original KB number:   2806842

Symptoms

After applying the latest product update to an organization that has been upgraded to the December 2012 Service Update, users notice that Opportunity line items no longer automatically calculate estimated revenue.

Cause

The default value for the revenue two-option set the isrevenuesystemcalculated field, was changed from System Calculated to User Provided. As a result, the estimated revenue field won't automatically calculate.

Resolution

Change the default value for the revenue field (isrevenuesystemcalculated) from User Provided to System Calculated.

  1. Select Settings, select Customizations, and then select Customize the System.
  2. In the Default Solution, under Components, expand Entities, and then expand Opportunity.
  3. Select Fields.
  4. Locate and double select the Revenue field (isrevenuesystemcalculated).
  5. Under Type, change the Default Value setting from User Provided to System Calculated.
  6. Select Save and Close.
  7. In the Default Solution, select Opportunity.
  8. Select Publish.