Internet Explorer can't display an HTTPS site when SSL 2.0 and TLS 1.2 are selected
Warning
The retired, out-of-support Internet Explorer 11 desktop application has been permanently disabled through a Microsoft Edge update on certain versions of Windows 10. For more information, see Internet Explorer 11 desktop app retirement FAQ.
This article provides a solution for Internet Explorer unable to display HTTPS websites.
Original product version: Internet Explorer 9 and later versions
Original KB number: 2851628
Symptoms
You select SSL 2.0 and TLS 1.2 in the Internet Explorer 11 security settings. When you access an HTTPS website in Internet Explorer, you receive the following error message:
Internet Explorer cannot display the webpage
Cause
The issue occurs because SSL 2.0 and TLS 1.2 aren't compatible with each other in Internet Explorer 9 and later versions.
Resolution
To use client-side certificates to establish an HTTPS connection over TLS 1.2, you must disable SSL 2.0. For more information, see Change security and privacy settings for Internet Explorer 11.
Note
SSL 2.0 is disabled by default.
Feedback
https://aka.ms/ContentUserFeedback.
Coming soon: Throughout 2024 we will be phasing out GitHub Issues as the feedback mechanism for content and replacing it with a new feedback system. For more information see:Submit and view feedback for