While configuring Dynamics CRM for phones and tablets, you receive an error message.

Symptoms
You have installed the Microsoft Dynamics CRM phone and tablet app and receive the following error when you attempt to connect to your Microsoft Dynamics CRM organization:


Windows / iOS Application:
"Your server is not available or does not support this application"


Android:
"This operation failed because you're offline. Reconnect and try again."

Cause
This error can occur in an on-premises environment if the certificate for the Microsoft Dynamics CRM website or federation server, such as ADFS, is not trusted.

This error can occur with an online organization if your organization is federated with Office 365 and the certificate for your federation server, such as ADFS, is not trusted.
Resolution
Make sure the SSL certificate used is trusted by using a publicly trusted certificate or add the Certificate Authority certificate for the certificate of the Microsoft Dynamics CRM website and the federation server to the device.

Adding the Certificate Authority certificate to the proper device will require you to export the Certificate Authority certificate from a device that has it and then import it. In most cases, you can simply get the exported certificate on the device and open it to install/import it.
More information
If you capture tracing, the following error is logged:

Windows 8:

"Security certificate required to access this resource is invalid"

iPad:

"Loading app failed due to SSL error"


For more information about installing the Certificate Authority certificate see the following articles:
Windows - http://social.technet.microsoft.com/wiki/contents/articles/2167.how-to-use-the-certificates-console.aspx
iOS - https://www.apple.com/hk/en/ipad/business/docs/iOS_6_Certificates_Sep12.pdf
Android - https://support.google.com/nexus/answer/2844832?hl=en


For information on how to enable tracing in CRM for Tablets, refer to the following article:

Enable tracing in CRM for tablets

http://www.microsoft.com/en-US/dynamics/crm-customer-center/enable-tracing-in-crm-for-tablets.aspx
Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.
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Article ID: 2899983 - Last Review: 08/11/2016 17:40:00 - Revision: 3.0

Microsoft Dynamics CRM 2013, Microsoft Dynamics CRM 2016, Microsoft Dynamics CRM 2015

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