We weren't able to connect to the remote server error when migrating from on-premises Exchange to Online

Original KB number:   2903050

Symptoms

When you try to perform a cutover migration from an on-premises Exchange organization that uses Outlook Anywhere (also known as RPC over HTTP) to Exchange Online, the migration engine doesn't create a migration endpoint. Additionally, you receive an error message that resembles the following:

Microsoft.Exchange.Data.Storage.Management.MigrationTransientException: We weren't able to connect to the remote server. Please verify that the migration endpoint settings are correct and your certificate is valid, and then try again. Consider using the Exchange Remote Connectivity Analyzer to diagnose the connectivity issues. ---> Microsoft.Exchange.Rpc.ServerUnavailableException: Error 0x6ba (The RPC server is unavailable) from cli_NspiBind

Cause

This issue may occur if one or both of the following conditions are true for Outlook Anywhere:

  • Authentication settings for Outlook Anywhere are incorrect.
  • RPC proxy configuration settings for Outlook Anywhere are incorrect.

Resolution

To resolve this issue, follow these steps:

  1. Make sure that the on-premises Outlook Anywhere client authentication method is set to Basic authentication. For more information, see one of the following articles, depending on the version of Exchange Server that you're running:

  2. Make sure that the RPC proxy server is correctly set up to use specific ports to communicate with Outlook Anywhere and that the on-premises domain controllers are listening on port 6004. For more information, see How does Outlook Anywhere work (and not work)?

  3. Verify Outlook Anywhere connectivity to the on-premises Exchange server. To do this, follow these steps:

    1. Connect to Exchange Online by using remote PowerShell. For more information about how to do this, see Connect to Exchange Online PowerShell.

    2. Run the following PowerShell commands:

      $pscred=Get-Credential
      
      Test-MigrationServerAvailability -Credentials $pscred -ExchangeOutlookAnywhere -ExchangeServer <Internal FQDN of the Exchange server> -RPCProxyServer <FQDN of the proxyserver> -Authentication Basic -EmailAddress <AdminEmail>
      

      If the verification is successful, you can create a migration endpoint in Microsoft 365.

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