You are currently offline, waiting for your internet to reconnect

Error "0x80090004 (NTE_BAD_LEN)" occurs when you try to sign in to Windows Live Messenger in Windows 8.1 or Windows Server 2012 R2

Symptoms
Consider the following scenario:
  • You have a computer that is running Windows 8.1 or Windows Server 2012 R2. 
  • You install Windows Live Messenger by installing Windows Live Essentials with Chinese Simplified language. 
  • You start Windows Live Messenger, and then you try to sign in.  
In this scenario, the sign-in attempt fails. Additionally, you receive an error message that resembles the following: 
0x80090004 (NTE_BAD_LEN) 
Cause
This issue occurs because code mishandling occurs during session key encryption.
Resolution

Update information

To resolve this issue, install update rollup 2903939. For more information about how to obtain this update rollup package, click the following article number to view the article in the Microsoft Knowledge Base:
2903939 Windows RT 8.1, Windows 8.1, and Windows Server 2012 R2 update rollup: December 2013

Status
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
More information
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
Properties

Article ID: 2906900 - Last Review: 12/10/2013 17:31:00 - Revision: 1.0

  • Windows 8.1
  • Windows 8.1 Enterprise
  • Windows 8.1 Pro
  • Windows Server 2012 R2 Datacenter
  • Windows Server 2012 R2 Essentials
  • Windows Server 2012 R2 Foundation
  • Windows Server 2012 R2 Standard
  • kbqfe kbfix kbsurveynew kbexpertiseadvanced KB2906900
Feedback