HOW TO: Use Qfixapp.exe in Windows XP

Support for Windows XP has ended

Microsoft ended support for Windows XP on April 8, 2014. This change has affected your software updates and security options. Learn what this means for you and how to stay protected.

This article was previously published under Q294416
This article has been archived. It is offered "as is" and will no longer be updated.
SUMMARY
This article describes the Quick Fix utility (Qfixapp.exe) that is included with the Application Compatibility Toolkit for Windows XP.Qfixapp.exe is a tool that includes pre-packaged fixes that provide an easy way to fix a program.

back to the top

Use Qfixapp.exe To Apply Program Fixes

You can use Qfixapp.exe to quickly apply various program fixes (AppFixes, also known as "shims") to a program to determine their effectiveness. Qfixapp.exe reads the %SystemRoot%\Windows\Apppatch\Sysmain.sdb database to produce a list of available fixes. When you select an AppFix, you can start the program executable (.exe) file, and the AppFix will be applied. If a suitable AppFix is found, the tool eventually helps you to generate and test matching file information. When you run Qfixapp.exe, you see the following items:
  • The The application for which to apply the fix(es) check box. This setting disables existing fixes in the database.
  • The Layer tab with the Choose one of the existing layers to apply to your app box that contains the following entries:
    256 Color
    640X480
    Disable Themes
    Internaltional
    LUA(Limited User Account)
    LUACleanUp
    NT4SP5
    ProfilesSetup
    Win2000
    Win95
    Win98
  • The Fixes tab. On this tab you can select the individual fixes that you want to apply.
back to the top

Example of How to Use Qfixapp.exe

  1. Start Notepad, and then click About Notepad on the Help menu. Note that the version is 5.1.
  2. Start Qfixapp.exe, click Win95, click Browse, and then open the Windows folder. Note that the Windows\System32 folder is protected by Windows File Protection, so it is not able to use the layers.
  3. Click Notepad.exe, click Open, and then click Run.
  4. Start Notepad, and then click About Notepad on the Help menu. Note that the version is now 4.0.
If you click ViewLog, you could see what AppFix(es) are being used. If you click Advanced, you could see information about the .exe file. You can click Add Matching Info, and then select files that are related to the .exe file to identify that particular program. After you finish that step, you could click Create Fix Support to add the layers with the Matching Information (GRABMI) and create an XML-based database that is named YourAppName.sdb. Note that in the preceding example it is named Notepad.sdb, and is in the AppPatch folder.

back to the top
REFERENCES
For additional information about the Windows Application Compatibility tool, click the following article number to view the article in the Microsoft Knowledge Base:
294895 How to Obtain the Windows Application Compatibility Toolkit
back to the top
act
Properties

Article ID: 294416 - Last Review: 12/06/2015 01:43:56 - Revision: 1.2

  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • kbnosurvey kbarchive kbenv kbhowto kbhowtomaster KB294416
Feedback