Enumeration Problems with CardBus Cards in Texas Instruments CardBus Controllers

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IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 Description of the Microsoft Windows Registry

If this article does not describe your hardware-related issue, please see the following Microsoft Resource Center to view more articles about hardware:
Symptoms
When you are running Windows 98 Second Edition or Windows Millennium Edition (Me) on a computer that supports the Advanced Configuration and Power Interface (ACPI) specification, you may experience the following symptoms with certain CardBus cards and certain Texas Instruments CardBus controller chip sets:
  • If you start your computer with no CardBus card inserted, and then you insert one of the affected CardBus cards, the following symptoms may occur:
    • The mouse pointer may alternate rapidly and continuously between a regular pointer and a busy (hourglass) pointer.
    • The computer may perform very sluggishly.
    • The CardBus card never finishes being initialized.
  • If you start your computer with one of the affected CardBus cards inserted, the following symptoms may occur:
    • The computer may stop responding (hang) while attempting to detect the CardBus card (for example, a PCI Ethernet controller).
    • Removing the CardBus card may allow the computer to finish detecting the device and installing drivers.
The exact symptoms may vary slightly depending on the computer, specific CardBus controller model, and CardBus card used.
Cause
On an ACPI-enabled computer that uses certain Texas Instruments CardBus controllers, inserting a CardBus card that does not support power management can result in a continuously asserted Power Management event (PME) being signal by the controller. This causes the card to be continuously re-enumerated.
Resolution
A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix should have the following file attributes or later:
   Date       Time     Version    Size    File name  Operating system   ------------------------------------------------------------------   5/18/2001  11:48am  4.90.3003  46,489  Cbss.vxd   Windows Me   5/03/2001   1:43pm  4.10.2226  44,457  Cbss.vxd   Windows 98                                                      Second Edition				

This hotfix supercedes the hotfixes that are documented in the following articles in the Microsoft Knowledge Base:
258010 Performance Problems Inserting CardBus Card with TI-14xx Controller
274334 Performance Problems Inserting CardBus Card with TI-1451 Controller
Status
Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.
More information
WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

In addition to installing this hotfix, you must add a value to the registry to enable the fix:
  1. Start Registry Editor (Regedit.exe).
  2. Locate and click the following key in the registry:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\CBSS\Hacks
  3. On the Edit menu, click Add Value, and then add the following registry value:
    Value name: TICStsChg
    Data type: DWORD
    Value data: 0x00000004
    Note that the TICStsChg value name is arbitrary. Any name works successfully.

  4. Quit Registry Editor.
The Texas Instruments CardBus controller chip sets that exhibit this behavior include:
  • PCI-1250 (VenDev ID 104C AC16)
  • PCI-1220 (VenDev ID 104C AC17)
  • PCI-1221 (VenDev ID 104C AC19)
  • PCI-1210 (VenDev ID 104C AC1A)
  • PCI-1450 (VenDev ID 104C AC1B)
  • PCI-1225 (VenDev ID 104C AC1C)
  • PCI-1251 (VenDev ID 104C AC1D)
  • PCI-1211 (VenDev ID 104C AC1E)
  • PCI-1251B (VenDev ID 104C AC1F)
  • PCI-4450 (VenDev ID 104C AC40)
  • PCI-4410 (VenDev ID 104C AC41)
  • PCI-4451 (VenDev ID 104C AC42)
  • PCI-1410 (VenDev ID 104C AC50)
  • PCI-1420 (VenDev ID 104C AC51)
  • PCI-1451 (VenDev ID 104C AC52)
Later models of Texas Instruments CardBus controller chip sets do not exhibit this behavior.

This behavior is only known to occur with the following CardBus cards:
  • Xircom CardBus Ethernet 10/100 (CEB-100BTX)
  • NEC Xircom 10/100 CardBus Network PC Card
For additional information about Windows 98 and Windows 98 Second Edition hotfixes, click the article number below to view the article in the Microsoft Knowledge Base:
206071 General Information on Windows 98 and SE Hotfixes
For additional information about Windows Me hotfixes, click the article number below to view the article in the Microsoft Knowledge Base:
295413 General Information Abut Windows Millennium Edition Hotfixes
HWSYSAPM
Properties

Article ID: 295629 - Last Review: 06/19/2014 12:54:00 - Revision: 4.0

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