You cannot distribute a driver package to a package share on a pull-distribution point

Symptoms
When you try to distribute a driver package to a package share on a pull-distribution point, the driver package is not distributed.

Additionally, error messages that resemble the following are logged in the Smsdpprov.log file:

CreateFolder failed; 0x8007007b
CContentDefinition::ExpandContentDefinitionItems failed; 0x8007007b
CContentDefinition::Expand failed; 0x8007007b

Note This problem occurs even though you can distribute the driver package to a regular distribution point.
Cause
This problem occurs when the following conditions are true:
  • A custom share name is set and 
  • A backslash (\) is used to include a subfolder.
Resolution

Hotfix information

A supported hotfix is available from Microsoft Support. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, go to the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Cumulative Update 1 for System Center 2012 R2 Configuration Manager installed.

Restart information

You do not have to restart the computer after you apply this hotfix.

Note We recommend that you close Microsoft Configuration Manager Administration Console before you apply this hotfix package.

Hotfix replacement information

This hotfix does not replace any previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

File nameFile versionFile sizeDateTimePlatform
Smsdp.dll5.0.7958.12073,169,96820-Feb-201401:35x64
Smsdp.dll5.0.7958.12072,305,71220-Feb-201401:35x86
Workaround
To work around this problem, do not set the custom share name to include a subfolder.
Status
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
References
Learn about the terminology that Microsoft uses to describe software updates.
Properties

Article ID: 2962927 - Last Review: 06/21/2015 17:28:00 - Revision: 2.0

Microsoft System Center 2012 R2 Configuration Manager

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