Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

Symptoms

Consider the following scenario:

  • You install an update on a computer that is running Windows 8.1, Windows RT 8.1, Windows Server 2012 R2, Windows 8, Windows RT, or Windows Server 2012.

  • During the update process, applications or services that are currently using files that are affected by the update will be shut down or restarted by Restart Manager. This enables the installation of the update.

  • You run a msiexec command together with a msirmshutdown=2 option to prevent applications or services from being shut down or restarted by Restart Manager.

In this scenario, the applications or the services are still shut down or restarted.

Cause

This issue occurs because the shutdown flag is set incorrectly by the msiexec.exe process.

Resolution

To resolve this issue, install update rollup 2984006 for Windows 8.1, Windows RT 8.1, or Windows Server 2012 R2 or update rollup 2984005 for Windows 8, Windows RT, or Windows Server 2012. For more information about how to obtain these update rollup packages, click the following article numbers to view the article in the Microsoft Knowledge Base:

2984006 September 2014 update rollup for Windows RT 8.1, Windows 8.1, and Windows Server 2012 R2

2984005 September 2014 update rollup for Windows RT, Windows 8, and Windows Server 2012

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×