Your mailbox can't be accessed or has limited functionality after a mailbox plan is changed from Kiosk to another plan in Office 365 dedicated/ITAR

Symptoms
In Microsoft Office 365 dedicated/ITAR, you can't access your mailbox, or the mailbox experiences limited functionality of a specific feature. This behavior occurs after a mailbox plan is changed from Exchange Online Kiosk D to Exchange Online Plan 1D or Exchange Online Plan 2D. After the mailbox plan is changed, the user can access Outlook only by using Outlook Anywhere.
Cause
This behavior occurs because the client access settings aren't set for the Exchange Online Plan 1D or Exchange Online Plan 2D in the mailbox plan provisioning process.
More information
The provisioning process that uses the SetMailboxType script is replaced by the mailbox plan provisioning process in Microsoft Office 365 dedicated/ITAR. This process includes the 13.1 version (for Exchange Server 2010) and the 2013 version (for Exchange Server 2013).

The mailbox plan provisioning process uses the following client access settings, depending on the plan class.

Plan classCustomer-managed settingsSettings managed by the mailbox plan provisioning process only
Standard (Exchange Online Plan 1D or Exchange Online Plan 2D plans)
  • MAPIBlockOutlookRpcHttp
  • MAPIBlockOutlookVersions
  • ActiveSyncEnabled
  • EWSEnabled
  • IMAPEnabled
  • MAPIEnabled
  • OWAEnabled
  • POPEnabled
  • OWAMailboxPolicy
Exchange Online Kiosk “Deskless Worker”
  • ActiveSyncEnabled
  • OWAEnabled
  • POPEnabled
  • MAPIBlockOutlookRpcHttp
  • MAPIBlockOutlookVersions
  • EWSEnabled
  • IMAPEnabled
  • MAPIEnabled
  • OWAMailboxPolicy


Notes

  • For the Exchange Online Plan 1D and Exchange Online Plan 2D plans, all settings are customer-managed. Therefore, no changes are made to these settings when you move to these plans.
  • For the Exchange Online Kiosk D plan, several settings are fully managed by the mailbox plan provisioning process. These settings are maintained on each run of the script. Customer-managed settings aren't changed. 

Changes made by the mailbox plan provisioning process

The mailbox plan provisioning process makes changes to a mailbox object in the following scenarios.

Scenario 1: Initial processing of a mailbox (for Exchange Server 2010 only)

The mailbox plan provisioning process sets all access and quota settings to their default values for both customer-managed and mailbox plan provisioning process-managed clients. In Exchange Server 2013, Microsoft Managed Services Service Provisioning Provider (MMSSPP) applies the client access and quota settings when the mailbox is created.

Scenario 2: Changes of the plan in the plan class (Exchange Online Plan 1D to Exchange Online Plan 2D)

Only the quota is updated (if it's different) because client access settings that are customer managed aren't updated.

Scenario 3: Changes of the plan class

  • Exchange Online Plan 1D or Exchange Online Plan 2D to Exchange Online Kiosk D

    The mailbox quota is updated (if it's different). The client access settings that are managed by the mailbox plan provisioning process are updated.
  • Exchange Online Kiosk D to Exchange Online Plan 1D or Exchange Online Plan 2D

    The mailbox quota is updated (if it's different). No client access settings are changed because all the settings are customer managed.
Scenario 4: Management of the Exchange Online Kiosk D plan settings

The Mailbox Plans provisioning process sets any of the settings to the plan defaults if there are any changes.

Scenario 5: Mailbox moved from on-premises Lotus Notes environment (Exchange Server 2010 only)

The mailbox plan provisioning process sets all access and quota settings to their default values for both customer-managed and mailbox plan provisioning process-managed clients. In Exchange Server 2013, MMSSPP applies the quota and client access settings when the mailbox is created.

Scenario 6: Mailbox moved from on-premises Exchange environment

The mailbox quota is set. Any other client access settings that are managed by the mailbox plan provisioning process are updated.
Status
This behavior is by design.
Properties

Article ID: 2987640 - Last Review: 10/14/2016 16:41:00 - Revision: 4.0

Microsoft Business Productivity Online Dedicated, Microsoft Business Productivity Online Suite Federal

  • vkbportal226 KB2987640
Feedback