Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

Symptoms

Intel Dynamic Platform and Thermal Framework (DPTF) drivers cause an operating system upgrade to roll back to the system version from which you started the upgrade on a Windows 8.1-based or Windows 8-based computer. This problem occurs on computers that have the the Intel Atom CPU Z3735F processor, the Intel Atom CPU Z3735G processor, the Intel Atom CPU Z3736F processor, or the Intel Atom CPU Z3736G processor installed.

Cause

This problem occurs because of a bug in the Intel DPTF driver that blocks the upgrade.

How to obtain this update

This update is automatically applied when you upgrade the operating system to the latest Windows version. No user interaction is required to apply this update.

Update detail information

Prerequisites

To apply this update, make sure that the computers have Intel DPTF drivers installed.

Note You must have an Internet connection when you upgrade the system.

Registry information

To apply this update, you do not have to make any changes to the registry.

Restart requirement

The computer restart is handled by the upgrade process.

Update replacement information

This update does not replace a previously released update.

The English (United States) version of this software update installs files that have the attributes that are listed in the following tables. The dates and times for these files are listed in Coordinated Universal Time (UTC). Be aware that dates and times for these files on your local computer are displayed in your local time and with your current daylight saving time bias. The dates and times may also change when you perform certain operations on the files.

For the Intel Atom CPU Z3735F, Intel Atom CPU Z3735G, Intel Atom CPU Z3736F, or Intel Atom CPU Z3736G processor in all supported 32-bit versions of Windows 8.1 and Windows 8.0

File name

File version

File size

Date

Time

DptfDevAmbient.sys

7.1.0.18

36,352

0-Sept-2014

08:26

DptfDevDisplay.sys

7.1.0.18

19,968

09-Sept-2014

08:26

DptfDevGen.sys

7.1.0.18

28,160

09-Sept-2014

08:26

DptfDevPower.sys

7.1.0.18

17,408

09-Sept-2014

08:26

DptfDevProc.sys

7.1.0.18

72,704

09-Sept-2014

08:26

DptfManager.sys

7.1.0.18

174,080

09-Sept-2014

08:26

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

This problem also occurs in computers that have the Intel Core, Intel Atom CPU Z3, or Intel Celeron J1 processor installed. For more information about the updates that are available for those processor models, go to the following articles in the Microsoft Knowledge Base:



3002388 You cannot upgrade to the latest Windows version on a computer that uses the Intel Core processor



3003476 You cannot upgrade to the latest Windows version on a computer that uses the Intel Atom CPU Z3 processor



3003478 You cannot upgrade to the latest Windows version on a computer that uses the Intel Celeron J1 processor



Third-party information disclaimer

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×