Office program errors when DisableThemes is configured in the __COMPAT_LAYER environment variable
Original KB number: 3028123
Symptoms
Consider the following scenario when you are running Windows 7 or Windows 8.
In Microsoft Word, when you attempt to open a document or save as, nothing appears to happen.
In Microsoft Excel, when you attempt to open a spreadsheet or save as, nothing appears to happen.
In Microsoft PowerPoint, when you attempt to open a presentation or save as, you receive the following error:
An error occurred while opening the file dialog. Please save your presentations, exit, and then restart PowerPoint.
In Microsoft Outlook:
You click Save As with an email message and you receive the following error:
The server is not available. Contact your administrator if this condition persists.
You click Open Calendar or Open Outlook Data File on the Backstage and receive the following error:
The server is not available. Contact your administrator if this condition persists.
Cause
These problems occur when you have the __COMPAT_LAYER
environment variable and its value contains DisableThemes
. This is shown in the following figure.
Resolution
To resolve this problem, remove the __COMPAT_LAYER
System variable from Environment Variables.
- Exit all Office programs.
- Open Advanced System settings.
- Windows 7:
- Click Start, right-click Computer, and then click Properties.
- Click Advanced system settings in the left pane.
- Windows 8:
- Right-click the Windows icon, and then click System.
- Click Advanced system settings in the left pane.
- Windows 7:
- On the Advanced tab, click Environment Variables.
- Under System variables, select
__COMPAT_LAYER
, and then click Delete. - Start your Office program(s).