Service Manager workflows do not execute, and list item changes are not saved

Symptoms
When new service requests (SRs) are submitted in Microsoft System Center 2012 Service Manager (SCSM 2012), the status of the SRs does not change from "New." Additionally, corresponding workflows do not execute for other work items, and the workflows display "Needing attention" in the console under Administration -> Workflows -> Status.

Also, after you change a list item in the console, close the console, and then reopen the console, the change is no longer present in the list.
Cause
This issue can occur if Microsoft SQL Server Service Broker is not enabled on the SCSM database. When the SCSM database is created, Service Broker is enabled. However, if a disaster-recovery scenario is encountered and the database has to be restored, Service Broker will be disabled when the restoration is finished, and Service Broker must be enabled manually. 
Resolution
To resolve this issue, enable SQL Server Service Broker. To do this, follow these steps.

Note Do this a time when the Management Server services can be stopped.
  1. On the management server or servers, open the Services.msc Microsoft Management Console (MMC) snap-in.
  2. Take one of the following actions, depending on your version of Service Manager:
    • For System Center 2012 Service Manager and System Center 2012 Service Manager Service Pack 1 (SP1), stop the following services:
      • System Center Management Configuration Service
      • System Center Management Service
      • System Center Data Access Service
    • For System Center 2012 R2 Service Manager, stop the following services:
      • System Center Management Configuration Service
      • System Center Data Access Service
      • Microsoft Monitoring Agent Service
  3. Start Microsoft SQL Server Management Studio on the Service Manager database server or on a computer that has the SQL Server tools installed and can connect to the Service Manager database server.
  4. Select New Query.
  5. In the navigation pane, expand Databases, and then click ServiceManager.
  6. In the details pane, type the following command, and then select Execute:
    SELECT is_broker_enabled FROM sys.databases WHERE name = 'ServiceManager'
  7. In the results that are displayed, verify the value that is displayed in the is_broker_enabled field. SQL Server Service Broker is disabled if this value is 0 (zero).
  8. In the details pane, type the following command, and then select Execute:
    ALTER DATABASE ServiceManager SET ENABLE_BROKER
  9. Verify that the command succeeded. If it did, SQL Server Service Broker is now enabled.
  10. On the management server or servers, take one of the following actions, depending on your version of Service Manager:
    • for System Center 2012 Service Manager and System Center 2012 Service Manager Service Pack 1, start the following services:
      • System Center Management Configuration Service
      • System Center Management Service
      • System Center Data Access Service
    • For System Center 2012 R2 Service Manager, start the following services:
      • System Center Management Configuration Service
      • System Center Data Access Service
      • Microsoft Monitoring Agent Service
  11. Close all open windows and dialog boxes.
  12. Test the workflows by restarting any workflow that needs attention.
  13. Submit a new service request, and verify that it moves to the "In Progress" state.
More information
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Article ID: 3029574 - Last Review: 01/26/2015 17:49:00 - Revision: 1.0

Microsoft System Center 2012 Service Manager, Microsoft System Center 2012 Service Manager Service Pack 1, Microsoft System Center 2012 R2 Service Manager

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