OffCAT automatically does an Offline scan when either OffCAT or Outlook is started with 'Run as administrator'

Symptoms
When you scan Outlook with the Microsoft Office Configuration Analyzer Tool (OffCAT), your Outlook scan is automatically configured as an Offline scan. This can be seen in the following figure where the 'Scan type' value indicates an 'Offline' scan.


Cause
This problem occurs when Outlook is either manually started with the 'Run as administrator' option (when you right-click the Outlook shortcut and select 'Run as administrator'), or you have the properties of the Outlook shortcut configured with the 'Run as administrator' option. OffCAT should be started in the same user context as Outlook. Where there is a difference in user context, then a Full scan with OffCAT cannot be performed.

When you have the Outlook shortcut properties configured to start Outlook with 'Run as administrator', the following registry data is configured:

Key: HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers

or

Key: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers

Type: REG_SZ
Value name: <path>\Outlook.exe

Value data:

Windows 10 or Windows 8.1:
^ RUNASADMIN

Windows 8:
~RUNASADMIN

Windows 7:
RUNASADMIN

RUNASAMDIN Registry Data

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.
Resolution
Disable the Run this program as an administrator option by using the following steps for your Outlook version and installation type (MSI or Click-to-Run) and your version of Windows. To determine your installation type of Office, see the More Information section.

Note Before you perform any of the following steps, please close both Outlook and OffCAT. Once you have performed the steps, restart Outlook and then restart OffCAT so that you can take a new scan of Outlook.

Per-User Setting or Per-Machine Setting

When the registry data in question falls under the HKEY_CURRENT_USER hive in the registry, this situation is considered to be per-user. When the registry data in question falls under the HKEY_LOCAL_MACHINE hive in the registry, this situation is considered per-machine. This information is displayed in the reading pane of your OffCAT scan report, as shown in the following two screen shots.

Per-User Setting:


Per-Machine Setting:
OffCAT Per-Machine Setting

The steps to update the 'Run as administrator' setting for both the Per-User and Per-Machine Settings are described in the following steps.


Outlook 2016 (MSI or Click-to-Run) on Windows 10, Windows 8.1, Windows 8, or Windows 7:

  1. Find Outlook.exe, which by default is in one of the following directories, depending on your installation type of Outlook and bitness of Windows and Outlook.
    • MSI-Based installation type:
      <diskdrive>\Program Files\Microsoft Office\Office16\
      <disk drive>\Program Files(x86)\Microsoft Office\Office16\
    • Click-to-Run installation type:
      <disk drive>\Program Files\Microsoft Office\root\Office16\
      <disk drive>\Program Files(x86)\Microsoft Office\root\Office16\
  2. Right-click Outlook.exe, and then click Properties.
  3. Under the Compatibility tab, click to clear the Run this program as an administrator option.

    Outlook 2016 Outlook.exe Compatibility settings

  4. Click Change settings for all users.
  5. Under the Compatibility for all users tab, click to clear the Run this program as an administrator option.

    Outlook 2016 Outlook.exe Compatibility for all users settings

  6. Click OK two times.



Outlook 2013 (MSI or Click-to-Run) on Windows 10 or Windows 8.1:

  1. Find Outlook.exe, which by default is in one of the following directories, depending on your installation type of Outlook and bitness of Windows and Outlook.
    • MSI-based installation type:
      <disk drive>\Program Files\Microsoft Office\Office15\
      <disk drive>\Program Files(x86)\Microsoft Office\Office15\
    • Click-to-Run installation type:
      <disk drive>\Program Files\Microsoft Office 15\root\Office15\
      <disk drive>\Program Files(x86)\Microsoft Office 15\root\Office15\
  2. Right-click Outlook.exe, and then click Troubleshoot compatibility.
  3. Select Troubleshoot Program.

    Program Compatibility Troubleshooter - Troubleshoot program

  4. Clear all options, especially The program requires additional permissions, and then click Next.

    Program Compatibility Troubleshooter - The program requires additional permissions

  5. Select the third option, No, I am done investigating the problem, and then click Next.

    Program Compatibility Troubleshooter - Done

  6. Click Close.
  7. Start Registry Editor. To do this, press Windows Key + R to open a Run dialog box. Type regedit.exe and then press OK.
  8. Navigate to the following registry path:

    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion\AppCompatFlags\Layers

  9. Double-click the REG_SZ entry with the name <path>\Outlook.exe where <path> is the path to Outlook.exe on your computer.
  10. In the Edit String dialog box, delete RUNASADMIN from the Value data box, by using the following steps for the different scenarios.
    1. RUNASADMIN is the only entry in Value data, as shown in the following figure.



      In this case, delete all the text, including ~ from the Value data box, as shown in the following figure.


    2. RUNASADMIN is listed alongside one or more other values in Value data, as shown in the following figure.



      In this case, delete only RUNASADMIN from the Value data box, as shown in the following figure.


  11. Click OK.
  12. Close Registry Editor.

Outlook 2013 (MSI or Click-to-Run) on Windows 8 or Windows 7:

  1. Find Outlook.exe, which by default is in one of the following directories, depending on your installation type of Outlook and bitness of Windows and Outlook.
    • MSI-based installation type:
      <disk drive>\Program Files\Microsoft Office\Office15\
      <disk drive>\Program Files(x86)\Microsoft Office\Office15\
    • Click-to-Run installation type:
      <disk drive>\Program Files\Microsoft Office 15\root\Office15\
      <disk drive>\Program Files(x86)\Microsoft Office 15\root\Office15\

  2. Right-click Outlook.exe, and then click Properties.
  3. On the Compatibility tab, click to clear the Run this program as an administrator option.

    Outlook 2013 Compatibility tab

  4. Click Change settings for all users.
  5. On the Compatibility for all users tab, click to clear the Run this program as an administrator option.

    Outlook 2013 Compatibility for all users

  6. Click OK two times.



Outlook 2010 on Windows 10, Window 8.1, Windows 8 or Windows 7:

  1. Find Outlook.exe, which by default is in one of the following directories, depending on your bitness of Windows and Outlook:

    <disk drive>\Program Files\Microsoft Office\Office14\
    <disk drive>\Program Files(x86)\Microsoft Office\Office14\
  2. Right-click Outlook.exe, and then click Properties.
  3. Under the Compatibility tab, click to clear the Run this program as an administrator option.

    Outlook 2010 Compatibility settings

  4. Click Change settings for all users.
  5. Under the Compatibility tab, click to clear the Run this program as an administrator option.

    Outlook 2010 All Users Compatibility settings

  6. Click OK two times.


More information
To determine whether your Office installation is Click-to-Run or MSI-based, follow these steps:
  1. Open Outlook.
  2. On the File menu, select Office Account.
  3. For Office Click-to-Run installations, an Update Options item is displayed. For MSI-based installations, the Update Options item isn't displayed.


Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.
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Article ID: 3047542 - Last Review: 12/08/2015 05:32:00 - Revision: 3.0

Outlook 2016, Microsoft Outlook 2013, Microsoft Outlook 2010, Microsoft Office Outlook 2007

  • KB3047542
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