FIX: Errors in client HTTP connections to the Unified Access Gateway redirect trunk after you install Rollup 1 for Forefront Unified Access Gateway 2010 Service Pack 4

Symptoms
After you install Rollup 1 for Microsoft Forefront Unified Access Gateway 2010 Service Pack 4, client HTTP connections to the Unified Access Gateway redirect trunk may intermittently receive one of the following error messages:

Error message 1:

You cannot access this site due to an internal error.

Error message 2:

You have attempted to access a restricted URL.

Cause
This problem occurs because Rollup 1 for Forefront Unified Access Gateway 2010 Service Pack 4 changed how the NLSessionC cookie for the HTTP redirect trunk is applied. An initial client connection to this trunk is successfully redirected to HTTPS. However, any successive client HTTP connections in the same session fail because of the missing NLSessionC cookie.
Status
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
References
Learn about how to create a redirect trunk in Forefront Unified Access Gateway.

Learn about the terminology that Microsoft uses to describe software updates.
Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.
Properties

Article ID: 3066351 - Last Review: 06/19/2015 17:05:00 - Revision: 1.0

Microsoft Forefront Unified Access Gateway 2010 Service Pack 4

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